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General Safety Summary 

Review the following safety precautions to avoid injury and prevent damage to 
this product or any products connected to it. To avoid potential hazards, use this 
product only as specified. 

Only qualified personnel should perform service procedures. 

While using this product, you may need to access other parts of the system. Read 
the General Safety Summary in other system manuals for warnings and cautions 
related to operating the system. 

To Avoid Fire or Personal Injury: 

Connect and Disconnect Properly: Do not connect or disconnect probes or test 
leads while they are connected to a voltage source. 

Observe All Terminal Ratings: To avoid fire or shock hazard, observe all 
ratings and markings on the product. Consult the product manual for further 
ratings information before making connections to the product. 

Do Not Operate With Suspected Failures: If you suspect there is damage to 
this product, have it inspected by qualified service personnel. 

Symbols and Terms: The following terms and symbols may appear in the online 
help. 

 

 

 

 

 

 
WARNING. Warning statements identify conditions or practices that could 
result injury or loss of life. 

 
CAUTION. Caution statements identify conditions or practices that could 
result in damage to this product or other property. 
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Terms on the Product: The following terms may appear on the product: 

 DANGER indicates an injury hazard immediately accessible as you read the 
marking. 

 WARNING indicates an injury hazard not immediately accessible as you 
read the marking. 

 CAUTION indicates a hazard to property including the product. 

 

Symbols on the Product: The following symbol(s) may appear in the product: 

 CAUTION  
Refer to Help 
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Preface 

This manual contains operating information for the TDSDDM2 Disk Drive 
Measurements Application. The manual consists of the following chapters: 

 The Getting Started chapter briefly describes the TDSDDM2 Disk Drive 
Measurements Application, lists oscilloscope compatibility, and provides 
installation instructions. 

 The Installation chapter gives a brief explanation on connection 
configuration. 

 The Configuration chapter briefly explains setting up the oscilloscope and 
the application trigger, and configuring the input waveforms. 

 The Operating Basics chapter covers basic operating principles of the 
application, setting up the application, taking measurements, and analyzing 
the results. 

 The Application Examples chapter includes examples of tests and 
measurements to give you ideas on how to solve your own measurement 
problems. 

 The GPIB Program Example chapter shows a simple GPIB program. 

 The Parameters chapter includes a diagram of the menu structure and 
descriptions of parameters. 

 The Measurement Algorithms appendix contains information on 
measurement guidelines and on how the application takes the 
measurements. 

 The Track Profile Plots appendix contains information about using track 
profile plots. 

 The GPIB Command Syntax appendix contains a list of arguments and 
values that you can use with the GPIB commands and their associated 
parameters. 
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Related Documentation 

In addition to the Online Help, you can access other information on how to 
operate the oscilloscope and application through the following related 
documents: 

 Installation Instructions; the installation instructions provide information on 
how to install software. 

 Oscilloscope Information; the user manual for your oscilloscope provides 
general information on how to operate the oscilloscope. 

 Programmer Information; the online help for your oscilloscope provides 
details on how to use GPIB commands to control the oscilloscope. 

  You can also download the file with programmer information and 
examples from the Tektronix Web site. Refer to the installation manual for 
information on how to download the file. 

Refer to the Optional Applications Software on a Windows-Based Oscilloscope 
Installation Manual for the following information: 

 Software warranty 

 List of all available applications, compatible oscilloscopes, and relevant 
software and firmware version numbers 

 Applying a new label 

 Installing an application 

 Enabling an application 

 Downloading updates from the Tektronix Web site 

You can find a PDF (portable document format) file for this document in the 
Documents directory on the Optional Applications Software on a Windows-
Based Oscilloscope CD. The CD booklet only contains information on installing 
the application from the CD and on how to apply a new label. 
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Conventions 

Online help topics use the following conventions: 

 Refers to the TDSDDM2 Disk Drive Measurements Application as the 
TDSDDM2 application or as the application. 

 Refers to any product on which this application runs as an "oscilloscope." 

 Menus and options may appear in gray if they are beyond the capability of 
the oscilloscope. 

 Displays of an oscilloscope are from a TDS7104 model; there may be subtle 
differences in the displays from other types of oscilloscopes. 

 When steps require a sequence of selections using the application interface, 
the ">" delimiter marks each transition between a menu and an option. For 
example, one of the steps to recall a setup file would appear as 
Measurements> Save/Recall> Recall.  

Using Online Help 

Online help has many advantages over a printed manual because of advanced 
search capabilities. Selecting Help on the right side of the application's Menu bar 
brings up the help file. 

The main (opening) Help screen shows a series of book icons and three tabs 
along the top menu, each of which offers a unique mode of assistance: 

 Table of Contents (TOC) tab - organizes the Help into book-like sections. 
Click a book icon to open a section; select any of the topics listed under the 
book. 

 Index tab - enables you to scroll a list of alphabetical keywords. Click the 
topic of interest Find tab - allows a text-based search. Follow these steps: 

 Find tab - allows a text-based search. Follow these steps: 

1. Type the word or phrase you wish to find in the search box. 

2. Select some matching words in the next box to narrow your search. 

3. Choose a topic in the lower box, and then click the Display button. 

 To print a topic, select the Print button from the help topics menu bar. 

 Select Options from the menu bar for other commands, such as to 
annotate a topic, keep the help window on top or to use system colors. 
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 Select the Back button to return to the previous help window. 
Sometimes you can jump from one topic to another through a 
hyperlink. If the Back button is "grayed out" or a jump is not available, 
choose the "Help Topics" button to return to the originating help folder.  

 Browse buttons (Next >> and Previous <<) allow you to move forward 
and backward through topics in the order of the Table of Contents 
(TOC). 

 Sometimes you will see the bolded word, "Note," in topic text. This 
indicates important information.  

Note: Certain aspects of the Online help are unique to applications that run on 
the oscilloscope. 
 

Green text  (with dotted underline) indicates a "Popup." Click the green text to 
display a brief help message. Click to return to the topic. 

Note: Green-underlined text indicates a Jump (hyperlink) to another topic. Select 
the green text to jump to the related topic. For example, click the green text to 
jump to the topic on Online Help and Related Documentation. 
 

 You can tell when the cursor is over an active hyperlink (button, jump, or 
popup), because the cursor "arrow" changes to a small "hand." 

Note the "light bulb" and word "Tip" in the graphic above. This graphic indicates 
additional information to help you function faster or more efficiently. 

Feedback 

Tektronix values your feedback on our products. To help us serve you better, 
please send us your suggestions, ideas, or comments on the application. 

Direct your feedback via email to techsupport@tektronix.com or FAX at  
(503) 627-5695 and include the following information. Please be as specific as 
possible. 

General information: 

 Instrument model number and hardware options if any, with serial number 

 Probes used 

 Your name, company, mailing address, phone number, FAX number, email 
address 
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 Please indicate if you would like to be contacted by Tektronix about your 
suggestion or comments 

Application specific information: 

 Software version number 

 Description of the problem such that technical support can duplicate the 
problem 

 The setup file of the oscilloscope and the application is also required to 
identify the problem 

 If possible, save the waveform on which you are performing the 
measurement as a .wfm file 

Note: To find the Software version number, click Help > About in the 
application. 
 

Once you have gathered this information, you can contact technical support by 
fax or through email. If using email, be sure to enter in the subject line 
"TDSDDM2 Problem" in the subject line, and attach the .wfm files. 

You can then attach the file to your email (depending on the capabilities of your 
email editor). 

  To include screen shots, from the oscilloscope menu bar, select File> 
Export…. The Export Dialog box displays. Enter a file name with a .bmp 
extension and Save. The file is saved in the C:\TDS7000\Images directory. You 
can then attach the file to your email (depending on the capabilities of your email 
editor). 





 

TDSDDM2 Disk Drive Measurements Application 1
 

Getting Started 

Product Description 

The TDSDDM2 Disk Drive Measurements Application is a Java-based 
application that enhances basic capabilities of some Tektronix oscilloscopes. 

The application provides disk drive measurements, can display the results as 
statistics or as a plot, and can save the results to a data log file. 

The figure below shows an example of statistical results for a TAA measurement 
in the application part of the display (lower half) and a Track Profile plot of those 
results in the oscilloscope part of the display (upper half). 

 

Figure 1: TDSDDM2 Disk Drive Measurements Application 

Note: There are no standard accessories for this product other than the manual. 
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Compatibility 

For information on oscilloscope compatibility, refer to the Optional Applications 
Software on Windows-Based Oscilloscopes Installation Manual, Tektronix part 
number 071-1888-XX. The manual is available as a PDF file. 

Requirements and Restrictions 

The Sun Java Run-Time Environment V1.4.2 or above must be installed on the 
oscilloscope to operate the TDSDDM2 application. 

The TDSDDM2 application does not support hard disk drives that mark the 
beginning of a track by the absence of a sector pulse. 

Note: This application may be compatible with future models of oscilloscopes 
that have different specifications. If this occurs, menus or options that are 
unavailable will appear dim if they are beyond the acquisition capability of the 
oscilloscope. 
 

Accessories 

There are no standard accessories for this product other than the manual. 

To connect the Read Signal input to an oscilloscope channel, Tektronix 
Differential Probes are recommended, such as the P6247 or P6248 probe for 
TDS7054 and TDS7104 oscilloscopes, or the P7330 probe for a TDS7404 
oscilloscope. 
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Installation 

Refer to the Optional Applications Software on a Windows-Based Oscilloscope 
Installation Manual for the following information: 

 List of applications, compatible oscilloscopes, and relevant software and 
firmware version numbers 

 Applying a new label 

 Installing an application 

 Enabling an application 

 Downloading updates from the Tektronix Web site 

Note: To The Optional Applications Software on Windows-Based Oscilloscopes 
Installation Manual contains up-to-date information and procedures. Since 
installation procedures may be different for the T DS7000 series and other 
oscilloscopes, be sure to check this manual before you install the software. 

 

If you need to locate the corresponding Portable Document Format (PDF) file of 
this document, you can find it in the Documents directory on the Optional 
Applications Software on a Windows-Based Oscilloscope CD. The CD booklet 
only contains information on installing the application from the CD and on how 
to apply a new label. 

Connecting to a System Under Test 

For best signal accuracy, you should use one differential probe and two standard 
probes. For connection to the Read signal, use a differential probe, such as the 
Tektronix P6247 or P6248 probe for the TDS7054 and TDS7104 oscilloscope, or 
the P7330 probe for the TDS7404 oscilloscope. For connection to the Index and 
Sector signals, use standard oscilloscope probes, such as the Tektronix P6139A 
passive probe or P6243 active probe for the TDS7054 and TDS7104 
oscilloscope, or the P7240 active probe for the TDS7404 oscilloscope. 
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The table below shows the default channel-to-signal assignments. You can 
change the channel assignments to match your configuration.  

Table 1: Primary setup channel assignments 
Table of Primary Setup Channel Assignments
Channel Description
Ch 1 Read signal from the disk drive preamp channel
Ch 2 Read Gate signal (optional)
Ch 3 Sector pulse, marking the beginning of the sector on the track
Ch 4 Index pulse, marking the beginning of the track

 

Note: The TDSDDM2 application does not support disk drives that mark the 
beginning of a track by the absence of a sector pulse. For this case, a timeout 
trigger setup is needed to identify the beginning of the track. 
 

There are two connection configurations, primary and secondary. 

 

 

 
P
Power down the SUT before connecting probes to it. 

 
WARNING. To avoid electric shock, you must ensure that power is removed 
from the SUT before attaching a probe to it. Do not touch exposed conductors 
except with the properly rated probe tips. Refer to the probe manual for 
proper use. 
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Primary Setup 

Use the primary setup if you want the oscilloscope to control the disk 
measurements. The primary setup is used for most configurations. Connect the 
disk drive to the oscilloscope as shown below. 

 

Figure 2: Primary setup connections 

 

Secondary Setup 

When using the secondary setup, you must specifically program the test 
measurement control sequences. Refer to the GPIB Program Example and to the 
GPIB Command Syntax topics for more information on how to control the 
application with a GPIB program.  
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Connect the disk drive to the oscilloscope as shown below. 

 

Figure 3: Secondary setup connections 
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Configuration 

There are configuration tasks that you should perform before you start taking 
measurements. For the most part, these tasks configure the oscilloscope and Disk 
Drive Measurements Application to correctly acquire the signals from the disk 
drive under test.  

These tasks are: 

• Setting Up the Oscilloscope Trigger  

• Setting Up the Application Trigger  

• Hysteresis  

• Configuring the Input Waveforms 

Note: You can find more information on setup parameters for specific 
measurements in about application parameters. 
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Setting Up the Oscilloscope Trigger 

If you use the Read Gate, User or Index Trigger mode, you must manually set up 
the trigger. To do so, follow these steps: 

1. Connect the Index, Sector, and Read signals to Ch 4, Ch 3, and Ch 1 
respectively.   

2. Go to Math in the oscilloscope menu bar and select Spectral Controls > T 
tab.  

 

Figure 4: Spectral Control T tab for a TDS7104 oscilloscope 

3. Use the Multipurpose (MP) knobs to set the Sample Rate to 500 MS/s, 
1.25 GS/s, 2.5 GS/s, 5 GS/s, or 10 GS/s. 

4. Use the MP knobs to set the Record Length to 50,000, 100,000, 200,000 or 
400,000. 

5. For NLTS measurements, set the Record Length to at least 200,000. 

6. Set up the trigger:  

a. Go to Trig in the menu bar, access the A Event (Main) Trigger Setup 
menu, select the A Event tab, and set the Coupling to DC. 
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b. Set the Slope to the appropriate edge for your disk drive signals, rising 
or falling. 

c. Set the Level to an appropriate level for your disk drive signals, or 
select Set 50%. 

d. Select the Mode tab, and set the Trigger Mode to Normal. 

e. Set the Holdoff to Auto. 

Setting Up The Application Trigger 

Before you begin to take measurements, you should specify the following trigger 
parameters: 

 Trigger mode, which selects the input trigger signal 

 Start Sector and Stop Sector (used with the Sector Trigger mode only), 
which specifies the range of sectors to be measured 

 Preamble (used with the Sector Trigger mode only), which the application 
uses to avoid acquiring the preamble 

Set up the trigger parameters as follows: 

7. Start the application. The way you start the application depends on the 
oscilloscope model. To start the application do one of the following: 

 Select File > Run Application > Disk Drive Measurements 2 in the 
oscilloscope menu bar. 

 Select App > Disk Drive Measurements 2 in the oscilloscope menu bar. 

 Select Analyze > Disk Drive Measurements 2 in the oscilloscope menu 
bar. 
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8. Select Inputs > Input/Trigger and select one of the following Trigger Modes: 

Table 2: Trigger modes 
Trigger Modes

Sector Select Sector mode if you want to perform a measurement
over a range of sectors rather than over the entire track.
The application sets up the following oscilloscope trigger
controls:
A Event trigger - the Source is the Index Pulse
B Event trigger - the Source is the Sector Pulse
A -> B Seq trigger (delayed trigger) - the Trig Event is the
Start Sector number, Horiz Delay is On, and the Trig on nth
event is the Preamble duration

Read
Gate

Select Read Gate mode if you want to trigger on the Read
Gate signal. The A -> B Seq is not used with this selection.

User Select User mode if you want to use your own custom
trigger setup. When you select User, the application does
not set up the oscilloscope trigger controls.
User is the default Trigger Mode selection.

Index Select Index mode if you want to trigger on the Index Pulse
signal. The A -> B Seq is not used with this selection.

 

Note: If you select the read Gate, User, or Index Trigger mode, you must 
manually set up the oscilloscope trigger as described in the topic, Setting Up the 
Oscilloscope Trigger. 
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9. For the Sector Trigger Mode, use the MP knob (or keypad) to select values 
for the Start Sector and Stop Sector options.  

Note: The A -> B Seq trigger has a minimum count setting of 1. If you want to 
trigger on sector 0, you must enter the value of N, where N is the total number of 
sectors on the track. The first Sector Pulse after the Index Pulse is sector 1. 
 

 

Figure 5: Sector Trigger Mode default values  

The following figure shows how the sectors are numbered with respect to the B 
Event trigger in the oscilloscope application. 

 

Figure 6: One track 

 

10. For the Sector Trigger Mode, set the Preamble option. Use the MP knob (or 
keypad) to select a value that is greater than the actual signal preamble 
duration. This ensures that the application does not acquire the preamble and 
excludes it from the measurement. 
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Hysteresis  

Many of the measurements search for a local event called a peak and trough pair. 
You can set the hysteresis level so that noise will not cause false identification of 
peaks in the Read waveform. For a peak or trough to be found, the signal must be 
greater than the hysteresis level.  

The application uses the value of the Hysteresis option in many measurements, 
such as TAA, PW50, Asymmetry (for TAA Snapshot and PW50 Snapshot 
measurements), Overwrite, Resolution, and Baseline Shift. The figure below 
illustrates the use of hysteresis to avoid false identification of peaks. 

  

  

Figure 7: Using hysteresis to avoid false identification of 
peaks 

To set the hysteresis levels, follow these steps: 

1. Select Inputs > General. 

2. Use the multipurpose knob (or keypad) to select a value in the Hysteresis 
option.  

The units for hysteresis are in divisions. The application uses the value for both 
the positive hysteresis level and the negative hysteresis level. 
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 For example, if you select a value of 2 divisions, the hysteresis levels are set to 
+2 divisions and -2 divisions above and below the waveform baseline.  

 

Figure 8: Hysteresis option  

Configuring the Input Waveforms 

Your configuration may not match the TDSDDM2 waveform assignments. The 
following table lists the Default channel assignments: 

Table 3: Default Channel assignments 
Description Channel
Read signal from the preamp channel Ch 1
Read Gate signal (optional)* Ch 2
Sector Pulse, marking the beginning of the sector on the track** Ch 3
Index Pulse, marking the beginning of the track** Ch 4
*  Uses this signal when you select the Read Gate Trigger Mode.
** Uses these signals when you select the Sector Trigger Mode.

 

Note: Oscilloscope channels (Ch1, Ch2, Ch3, and Ch4) connect to real, live 
signals (waveforms) as opposed to waveforms that have been saved as .wfm files 
and can be recalled into reference memory (Ref1, Ref2, Ref3, and Ref4). 
 

If necessary, you can reconfigure the input waveforms to match your disk drive 
configuration. To do so, follow these steps: 

1. Go to the Inputs menu in the menu bar and select Input/Trigger.  

2. Use the list box for each signal and select the waveform that matches your 
configuration. 
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Operating Basics 

This section contains information on the following topics and tasks: 

• Application interface  

• Using basic oscilloscope functions  

• Setting up the application  

• Taking measurements  

• Analyzing the results  

• Saving the results to a file  

• Viewing a data log file  

• Saving and recalling setups  

• Exiting the application  

Application Interface 

The application uses a Windows interface.  

 

 

Figure 9: Application interface 
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Note: The oscilloscope application shrinks to half size and appears in the top 
half of the display when the application is running. 
 

The following table lists the interface items with a brief description of each: 

Table 4: Application interface items 
Item Description
Menu bar Located at the top of the application display and

contains application menus
Area Visual frame that encloses a set of related options
Option button Button that defines a particular command or task
List box Box that contains a list of items from which you can

select one item
Box Box that you can use to type in text, or to enter a value

with the Keypad or a Multipurpose knob
Scroll bar Vertical or horizontal bar at the side or bottom of a

display area that can be used for moving around in that
area

Browse Displays a window where you can look through a list of
directories and files

Command button Button that initiates an immediate action
  

Basic Oscilloscope Functions 

You can use the Help menu to access information about the oscilloscope. You 
can also use other oscilloscope functions and easily return to the application. 

The application includes Online Help about the application menus and controls.  

To display the Online Help, follow these steps: 

1. Choose the Help menu from the TDSDDM2 menu bar. 

2. Use the Contents, TOC, or Index tabs to navigate through the help.  

Minimizing and Maximizing the Application 

The application remains displayed when you minimize the oscilloscope. To 
minimize the application, select Measurements > Minimize or click the Hide 
button in the application. 

The way you maximize the application depends on the oscilloscope model. To 
maximize the application do one of the following: 

 Select the App > Restore Application on the oscilloscope menu bar. 
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 Select the Analyze > Restore Application on the oscilloscope menu bar. 

 Click the App button on the top right of the oscilloscope. 

Returning to the Application 

When you access oscilloscope functions, the oscilloscope fills the display. You 
can access oscilloscope functions in the following ways:  

 Select the Exit button in the application display 

 Choose the Menu-bar or Toolbar mode on the oscilloscope and access 
menus 

 Press front-panel buttons 

To return to the application, choose the App button on the Top menu bar of the 
oscilloscope. 

 

Figure 10: Returning to the application 
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Application Directories and File Names 

The application uses directories to save and recall setup files and also uses 
extensions appended to file names to identify the file type. 

Default Directories 

 The following table lists default directory names: 

Table 5: Default directory names 

 

Directory Used for
C:\TekApplications\tdsddm2 Home location
C:\TekApplications\tdsddm2\log Data log files
C:\TekApplications\tdsddm2\setup Setup files
C:\TekApplications\tdsddm2\waveforms Waveform files

 

File Name Extensions 

The following table lists File name extensions: 

Table 6: File name extensions  
Extensions Descriptions
.csv Log file that uses a "comma separated variable" format
.ini Application setup file
.set Oscilloscope setup file saved and recalled with an .ini file; both

files will have the same name
.wfm Waveform file that can be recalled into a reference memory

 

Setting Up the Application 

You can set up the application to take disk drive measurements from the SUT, 
you can plot the results, and you can save the statistical results to a data log file.  

Selecting a Measurement 

There are four Measurements menu items. Two allow you to select and configure 
a measurement, one allows you to save and recall measurement setups, and one 
allows you to minimize the application.  

 To access the TAA/PW50 Measurements menu, go to the Measurements menu 
in the menu bar and choose TAA/PW50.  
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Figure 11: TAA/PW50 Measurements menu 

The following table lists the TAA/PW50 measurements with a brief description 
of each: 

Table 7: TAA/PW50 Measurement options  
Option Description
TAA Track Average Amplitude: average peak–to–peak value

of data from the Read signal input
TAA+ Average positive peak value
TAA- Average negative peak value
TAA Snapshot Provides a summary of TAA measurements
PW50 Pulse Width at 50% of the Peak Amplitude: average

pulse width at 50% of the peak, that includes both peaks
and troughs; can also measure around a complete track
if specified in the oscilloscope trigger setup

PW50+ Includes only the positive peaks
PW50– Includes only the troughs
PW50 Snapshot Provides a summary of PW50 measurements

 

The following table lists options in the Limit Test area with a brief description of 
each. For some measurements, such as TAA, PW50, Overwrite, Resolution, and 
Baseline Shift, these are the only options. 

Table 8: Limit Test options 
Option Description
On/Off Enables the application to display PASS or FAIL results based

on the limits
Upper Limit Maximum limit allowed for the measurement mean value
Lower Limit Minimum limit allowed for the measurement mean value

 
The following figure shows the methods you can use to enter Limit Test values: 
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Figure 12: How to enter Limit Test option values 

 The following table shows the measurement options: 

Table 9: Limit Test entry methods 
Entry method Description
Keypad Icon appears when you select the box; select and use to enter a

value
Multipurpose
knob

When you select the multipurpose (MP) knob, a line appears
between the knob and the box; turn the knob on the
oscilloscope to select a value
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NLTS/Other Measurements menu 

To access the NLTS/Other Measurements menu, go to the Measurements menu 
in the menu bar and select NLTS/Other. The following figure shows the 
NLTS/Other measurements menu: 

 

Figure 13: NLTS/Other Measurements menu 
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The following table lists the NLTS/Other Measurements Options with a brief 
description of each: 

Table 10: NLTS/Other Measurement options 
Option Description
NLTS Initial Non–Linear Transition Shift; measures NLTS caused by a

transition in the current bit cell which reverses the direction of
the previous magnification

NLTS 1st
Adjacent

Measures NLTS caused by a transition in the previous bit cell
which opposes the transition in the current bit cell; also called
the first adjacent

NLTS 2nd
Adjacent

Measures NLTS caused by a transition which is two bit cells
before the current bit cell; also called the second adjacent

NLTS Snapshot Provides a summary of NLTS measurements
SNR Signal–to–Noise Ratio; determines the ratio of the variance of

the readback signal to the readback noise and expresses the
ratio in dB units

Asperity Large signal caused when the disk drive head strikes the
media; the application compares the mean value of TAA
samples to the amplitudes of peak/trough pairs and saves
values that exceed the Threshold option; also saves the
sector number and time relative to the start of the waveform
data record

Overwrite Determines the amount of residual signal remaining from a
previous write when new data is written to the same location

Resolution Determines the ratio of a high–frequency TAA pattern to a
low–frequency TAA pattern, expressed as a percentage (write
a low–frequency TAA pattern to a track, measure it, erase it,
write a high–frequency TAA pattern to the same track, and
measure again)

Baseline Shift Difference between the baseline of the positive pulse and the
baseline of the negative  pulse
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The following figure shows the parameter options for NLTS measurements: 

 

Figure 14: NLTS Parameter options  

The following table lists the NLTS Parameter options with a brief description: 

Table 11: Table of NLTS Parameter options  
Option Description
Pattern Dur Initial length of time for one repetition of the pseudo–random bit

data pattern; enter your best estimate
Dur Toler Tolerance (accuracy) of the initial value in the Pattern Dur

option; a smaller percentage helps the application take the
measurement more quickly

Poly Index Application uses x=2 to obtain condensed notations of selected
pseudo–random binary sequence polynominals; you should use
the same polynominal that generates the data pattern written to
the media; when you use the multipurpose knob, invalid
polynominals do not appear as selections

 

Note: The application initially uses the estimated value that you enter for the 
Pattern Dur option. The application then uses autocorrelation to precisely 
measure the duration pattern and replaces the estimated value. 
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An example of how the application uses x=2 to calculate the polynominal index: 

The following figure shows an example of how the application uses x = 2 to 
calculate the polynominal index. 

 
The following figure shows the parameter options for the SNR measurement: 

 

 
Figure 15: SNR Parameter options 
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The following table lists the SNR Parameter Options with a brief description: 

Table 12: SNR Parameter options  
Option Description
Pattern Dur Number of bits per pattern period for general patterned data,

depending on what was previously recorded on the hard disk
For pseudo–random data of pseudo–noise type generated with
shift registers (pseudo–random binary sequence), number of
bits per pattern is 2L–1, where L is the order of the characteristic
polynominal

Dur Toler Tolerance (accuracy) of the initial value in the Pattern Dur
option; a smaller percentage helps the application take the
measurement more quickly

Bits/Pattern Periodic signals used for SNR measurements defined as
isolated periodic transitions (low frequency), isolated high–
density periodic transitions (high frequency), or patterned data
such as pseudo–random sequences; use two bits per pattern
for low–frequency and high–frequency patterns

 

The value for the Threshold option determines if the application identifies the 
signal as an asperity.  

 

Figure 16: Asperity Parameter options 
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Configuring a Measurement 

There are three Inputs menus that allow you to configure the input waveforms for 
measurement. To configure these inputs use Inputs/Trigger, Inputs/Filters, and 
Inputs General. 

To configure the input waveforms for a measurement, go to the Inputs menu in 
the menu bar and choose Inputs/Trigger.  

 

Figure 17: Input/Trigger menu  

The application has the following Input Channels options:  

 Read Signal: a waveform that performs a read operation from a sector 

 Read Gate: a waveform that indicates the beginning of a read operation; the 
application Trigger mode must be set to Read Gate to use this input 

 Sector Pulse: a waveform that indicates the beginning of a sector; the 
application Trigger mode must be set to Sector to trigger with this and the 
Index Pulse inputs 

 Index Pulse: a waveform that indicates the beginning of a track; the 
application Trigger mode must be set to Index or to Sector to trigger with 
this input. 
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The following table lists the Trigger Options with a brief description of each: 

Table 13: Trigger options 
Option Description
Mode

Sector Triggers on the Sector Pulse and Index Pulse inputs;
uses oscilloscope delayed triggers to monitor various
sectors

Read Gate* Triggers on the Read Gate input; since delayed triggers
are not used, you must program the disk drive to
sequence through a range of sectors and leave a delay
that is long enough for the application to take a
measurement

User* Uses the oscilloscope trigger exactly as specified
Index* Triggers on the Index Pulse input; oscilloscope delayed

trigger is not used
Preamble** Time required to initialize a disk drive before signals

become stable; the duration of the preamble varies
between disk drive manufacturers

Start Sector** Specifies the sector on which to start the measurement
Stop Sector** Specifies the sector on which to stop the measurement
* Refer to Setting Up the Oscilloscope Trigger.
** Only available when Sector is the trigger mode.

 

Note: For more information on how the application Trigger modes affect the 
oscilloscope trigger controls, refer to step 2 of Setting Up the Application 
Trigger. 
 

You can modify the Read Signal input by applying filters that block specific 
frequency bands. You can configure each filter as either a Highpass to block out 
the low frequency band, or as a Lowpass to block out the high frequency band. 
You can also configure the filters by selecting Slope and a Cutoff Frequency 
based on the sample rate. 

To configure a filter for a measurement, go to the Inputs menu in the menu bar 
and choose Filters.  
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Figure 18: Input Filters menu 
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The following table lists the options for Filter 1 and Filter 2 with a brief 
description of each: 

Table 14: Filter options 

Option Description
On/Off Enables the application to use a filter as defined by the

remaining options
Cutoff Freq. Excludes frequencies above (Low pass filter) or below

(High pass filter) the value specified for measurements
Update Updates the Cutoff Freq value if you change the Sample

Rate (Horizontal Scale knob) of the oscilloscope.
The Min and Max values show the range for the Cutoff
Freq option; the Min value is 5% of the sample rate and the
Max value is 35% of the sample rate

Type
Highpass Blocks the low frequency band and passes on only the high

frequency band of the waveform
Lowpass Blocks the high frequency band and passes on only the low

frequency band of the waveform
Slope Defines the slope of the filter in dB/octave units
Store In Selects the reference memory in which to store the filtered

waveform, if any
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The following figure shows the filter characteristics of the various filters: 

 

 

Figure 19: Filter characteristics 

 

When you use both filters, the application first applies Filter 1 to the Read Signal 
input and then Filter 2. You should be aware that you could select a Cutoff 
Frequency value that filters out the entire waveform or all but a small amount of 
noise. The figure below shows the spectrum of the waveform passed to take 
measurements when you use both the Highpass and the Lowpass filters. 
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Figure 20: Using both the Highpass and Lowpass filters 

At the beginning and end of the filtered waveform, there will be a transient 
response caused by response of the filter to a discontinuity. You can use Gating 
in the Inputs General menu to exclude the discontinuity from measurement 
calculations. To do this, follow these steps: 

1. Select Inputs > Filters > On > Store In and the desired reference memory, 
Ref1, Ref2, Ref3, or Ref4. 

2. Select Single Mode and press  to start the measurement sequence. 

3. Remove the Read Signal input waveform from the display. If the input is a 
channel, press the front-panel channel button to remove the waveform. 

4. Observe the displayed Ref waveform and verify that the amplitude is 
correct. 

5. You can see transient responses at the beginning and the end of the 
waveform. 

6. Select Inputs > General > Gating > On. 
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7. Move the vertical cursors so that there are no transient responses between 
them; this excludes the transient responses from the measurement. 

8. Press  to start the measurement sequence. 

9. Repeat step 3 to remove the Read Signal waveform from the display. 

10. Observe the displayed Ref waveform. If necessary, adjust the Cutoff 
Frequency value; steeper slopes yield longer transient responses. 

11. If necessary, repeat step 6. 

12. Select Inputs>Filters>Store In>None. The application will display 
measurement results faster when reference memories are not used. 

When you start the application, or recall the default setup, the application uses 
the current oscilloscope sample rate to calculate a Min and Max range for Cutoff 
Frequency values. The Min and Max range displays at the bottom of the Inputs 
Filter menu. The application also sets the Lowpass filter to 15% of the sample 
rate and the Highpass filter to 10%. You can adjust the Cutoff Frequency value 
within the Min and Max range. 

When you change the sample rate and choose the Update command button, the 
Min value is set to 5% of the sample rate and the Max value is set to 35% for 
both filters. The application retains the value of the Cutoff Frequency if it is 
within the updated range. If the value is outside the updated range, the 
application adjusts the Cutoff Frequency to the closest value within the updated 
range. 

Note: If the value of the Cutoff Frequency is below the updated range, the 
application sets it to the Min value. If the value is above the updated range, the 
application sets it to the Max value.  
 

To change the sample rate and adjust the filter frequencies, follow these steps: 

1. Use the Horizontal Scale knob on the oscilloscope to change the sample 
rate. 

2. Choose the Update command button for either filter. The Min and Max 
values for both filters change relative to the new sample rate. 

3. Adjust the Cutoff Frequency option according to your needs.  

To configure the hysteresis or the gating for a measurement, go to the Inputs 
menu in the menu bar and choose General. 
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Figure 21: Inputs General menu 

The following table lists the General menu with a brief description of each: 

Table 15: General options  
Option Description 
Hysteresis Filters out noise that could cause false identification of peaks  
Gating Area between cursors on the waveform from which 

measurements are taken 
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Taking Measurements 

If you want to change trigger settings or localize the measurement, you should do 
so before you take any measurements.  

Note: If you select a reference or math waveform as the source, you will need to 
recall and display the waveform before the application can take a measurement. 
For an example from the tutorial on how to do this, Refer to Recalling a 
Waveform File. 

Remember to select Reset to set the results to zero if you change the oscilloscope 
Vertical or Horizontal time settings between measurements. 
 

Taking New Measurements 

The Sequence control menu is always accessible in the lower right part of the 
application display. The following figure shows the Sequence Control menu: 

 

 

Figure 22: Sequence Control menu 
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To acquire data from waveforms, follow these steps: 

1. Select a Sequence mode, refer the following table: 

Table 16: Sequence Control menu 
Option/button Description

Mode
Single

If the input source is Ch1, Ch2, Ch3, or Ch4, the
application acquires a new waveform; for all
sources, the application performs measurements on
the waveform, and stops

Free Run Repeatedly acquires the input waveform(s) and
takes measurements.

Start/Continue button Starts to take measurements from the input
waveform(s)
When paused, continues taking measurements

Pause button Pauses and resumes when you select the Continue
button or stops when you select the Stop button

Stop button Stops taking measurements
Reset button Resets all result values to zero

 

Note: The Sequence Control menu is always accessible in the right side of the 
application display. 
 

2. Press the  to start the acquisition. 

Note: Do not change oscilloscope settings while taking a measurement, since this 
can cause an invalid measurement. 
 

Localizing Measurements 

By specifying the trigger position, the starting point, and the length of the 
waveform, you can effectively filter out information that is not useful to analyze 
before taking a measurement. Refer to Setting up the Oscilloscope Trigger for 
information on how to adjust the Record Length and the Sample Rate in the  
Math > Spectral Controls menu (T tab) in the oscilloscope application.  

There is an alternative method to control the amount of data to measure without 
using gated cursors or specifying a range of sectors. You can do this by adjusting 
the Preamble Duration in the application Sector menu and the Record Length or 
Horizontal Scale in the oscilloscope horizontal menu. By specifying both the 
starting point and the total length of the measurement in this way, you can 
effectively size the area of interest. 
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Note: If an error message displays because there are not enough cycles from 
which to take a measurement, you should increase the Record Length or the 
Horizontal Scale. 
 

Analyzing the Results 

You can view the results as statistics or graphically as a plot. The following 
figure shows an example of the results display formats: 

 

 

Figure 23: Track Profile Plot example 

Note: Stop the acquisition before viewing the results as plots if you are 
taking.Measurements in the Free Run mode. 
 

 

You can also log the data to a "csv" file for viewing in a spreadsheet, database. 
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Figure 24: Example of viewing data in a .csv file 

Note: Statistical results vary widely across the different measurements. Because 
of this, each measurement has a unique format for the statistics in a log file. 
 

Viewing Statistics 

To access the View Results menu, go to the View menu in the menu bar and 
choose Results. Refer to the Applications Examples section to see examples of 
statistical results for each type of measurement. 

The statistical information that displays will vary by measurement. In general, 
the View Results menu contains statistical values for the mean, the maximum 
(Max), the minimum (Min), the standard deviation (StdDev), the SNR statistics 
(StatSNR), the number of peaks, troughs or peak/trough pairs used for the 
average values (num avg), and the sector number. 
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Viewing Plots 

There is one plot format: Track Profile. The format plots the results such that the 
vertical axis represents the mean measurement value and the horizontal axis 
represents the measurement number.  

To access the Plot Track Profile menu, go to the Plots menu in the menu bar and 
choose Track Profile.  

 

Figure 25: Plot Track Profile menu 

The following table lists the Plot Track Profile options with a brief description of 
each: 

Table 17: Plot Track Profile options 
Option Description
On/Off Enables the application to plot track data
Store Profile In: Selects the reference memory in which to store data for the

plot
Reset Clears all data in the plot

 
When the application trigger mode is set to Sector, the Plot Track Profile menu 
also contains the following readouts: 

 Value at Cursor displays the measurement value and is in units relative to 
the measurement (V, MHz, dBs). 

 Sector at Cursor displays the measurement number or the sector number at 
the cursor 

For more information on Track Profiles, refer to Creating and Viewing Track 
Profile Plots. 
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Clearing Results 

To reset all results to zero, choose the Reset button in the Sequence Control 
menu. You do not have to wait for a measurement to complete to reset the 
results. 

Saving Results to a File 

You can save (log) the results for all active measurements as statistics to a data 
log file. 

Note: The application does not log results from the Overwrite or the Resolution 
measurements. 
 

Logging Statistics 

Logging saves the statistical results from measurements to a data log file. To 
access the Log Statistics menu, go to the Log menu in the menu bar and choose 
Statistics. The following figure shows the Log Statistics menu. 

 

Figure 26: Log Statistics menu 
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The following table lists the Log Statistics options with a brief description of 
each: 

Table 18: Log Statistics options 

Option/button Description
Logging Enables the application to save the statistical results for all

active measurements, as well as the individual results to a
data log file

Clear Deletes the data log file; you must disable the logging
before you can clear the contents of the data log file

Save Current Stores the current measurement results in a “comma
separated variable” formatted file (.csv file) that you can
view at a later time

Log File Name:
Browse

Allows you to select the directory in which to save the data
log file and to enter a name for the file; the extension must
be .csv

 
The following figure shows an example of the Log file directory that displays 
when you select Browse. 

 

Figure 27: Log file directory 
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Data Log File Format 

The data log file consists of one header row and rows of logged information. The 
header row contains the application name, the version number of the application, 
and the date and time on which the file was created. The remaining rows contain 
information for the measurements. The information will vary with the 
measurements being logged. 

Note: If you are using a GPIB program to execute the application, such as in 
automated test environments, you can add your own annotation through the 
logAnnotate GPIB command. You can add information consisting of up to 20 
characters; the custom information will appear after the date and time in the 
rows of logged data. 
 

Viewing a Data Log File 

You can view the .csv data log file (comma separated variable format) in a 
spreadsheet, database, and text editing or data analysis program for further 
analysis.  

You must take measurements in Free Run mode to accumulate data points and 
store them in one data log file. Display a spreadsheet example of a data log file 
(csv).  

Note: You can use Notepad or Wordpad to quickly view the results in the data 
log file. 
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Saving and Recalling Setups 

You can use the Save/Recall Measurements menu to save and recall different 
configuration setups. To access the Save/Recall Measurements menu, go to the 
Measurements menu in the menu bar and choose Save/Recall. The following 
figure shows the Save/Recall Measurements menu. 

 

Figure 28: Save/Recall Measurements menu 

 

You may also wish to display the Save/Recall Measurement Options. 

Note: The Measurements > Save/Recall function includes the settings of the 
oscilloscope application. When you exit the application, you can choose whether 
to restore the settings of the oscilloscope to those present before starting the 
application. 
 

 

 

 
CAUTION. Do not edit the .ini or the .set files, or recall setup files not 
generated by the application, since this can cause the application to become 
unstable. 
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Table 19: Save/Recall Measurement options 

Option Description
Save Allows you to select a file in which to save the application

setup
Recall Allows you to select a file from which to recall the application

setup
Default Recalls the Default application setup values
File name for
Save/Recall

Displays the name of the last file used to save or recall a
setup

 

Note: The Measurements > Save/Recall function includes the settings of the 
oscilloscope application. When you exit the application, you can choose whether 
to restore oscilloscope settings to those present before starting the application.  

Do not edit the .ini or the .set files, or recall setup files not generated by the 
application, since this can cause the application to become unstable. 
 

Saving a Setup 

To save the application settings to a setup file, follow these steps: 

1. Select Measurements > Save/Recall. 

2. Select the Save button.  

3. Select the directory in which the setup file will be saved. 

4. Select or enter a file name. The application appends an ".ini" extension to 
the name of setup files. 

5. Choose Save. 

Note: The application also saves the oscilloscope setup to a ".set" file when you 
save an application setup. Both the application ".ini" file and oscilloscope ".set" 
file has the same file name. 
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Recalling a Saved Setup 

To recall the application and oscilloscope settings from a saved setup file, follow 
these steps: 

1. Select Measurements > Save/Recall. 

2. Select the Recall button.  

3. Select the directory from which the setup file will be recalled. 

4. Select or enter a setup file name. 

5. Choose Recall. 

Note: The application also recalls the oscilloscope setup from a ".set" file when 
you recall an application setup. 
 

Recalling the Default Setup 

To recall the application settings from the Default setup file, follow these steps: 

1. Select Measurements > Save/Recall. 

2. Choose Recall default values. 

Exiting the Application  

To exit the application, choose Exit. When you exit the application, you can 
select to keep the oscilloscope setup currently in use with the application or to 
restore the oscilloscope setup that was present before you started the application. 
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Tutorial 

This tutorial teaches you how to set up the application, take a measurement, view 
the results, and log the results. Refer to the topic, About Basic Operations, for 
more operating information. 

Before you begin the tutorial, you must do the following tasks: 

 Set up the oscilloscope  

 Start the application  

 Recall a waveform file  

Note: Displays of an oscilloscope are from a TDS7104 model; there may be 
minor differences in the displays from other types of oscilloscopes. 
 

Setting Up the Oscilloscope 

To set up the oscilloscope, follow these steps: 

1. Go to the File menu in the menu bar and select Recall Default Setup to set 
the oscilloscope to the default factory settings. 

2. Press the individual CH 1, CH 2, CH 3, and CH 4 buttons as needed to 
remove active waveforms from the display. 
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Starting the Application 

To perform these lessons, the application must be installed and enabled on the 
oscilloscope. Refer the installation procedure.  
The way you start the application depends on the oscilloscope model. To start the 
applications do one of the following: 

 Select File > Run Application > Disk Drive Measurements 2 in the 
oscilloscope menu bar. 

 Select App > Disk Drive Measurements 2 in the oscilloscope menu bar. 

 Select Analyze > Disk Drive Measurements 2 in the oscilloscope menu bar. 

 Application Startup (Measurements) Menu 

 

Figure 29: Starting the application 
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Recalling a Waveform File 

The application includes a TAA waveform that you can use with this tutorial. 
The taapw50.wfm file is from a Read Signal.  

To recall the taapw50.wfm file to Ref1 on to the oscilloscope, follow these steps: 

1. Go to the File menu in the menu bar and access  
Reference Waveforms > Reference Setup.  

 

Figure 30: Oscilloscope reference waveform setup 
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2. Select the Ref 1 tab and Recall. Choose the 
c:\TekApplications\tdsddm2\waveforms directory.  

 

Figure 31: Waveform directory to recall reference waveforms 

 

3. Select the taapw50.wfm file and select Recall. 

4. To return to the application, choose the App button in the Menu bar.  
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Taking a TAA Measurement 

In this example, you will learn how to use the application to take a Track 
Average Amplitude (TAA) measurement. To take a TAA measurement, refer to 
the Inputs/Trigger menu setup below and follow these steps: 

1. To return to the application, choose the App button in the Menu bar. 

2. Select Inputs > Input/Trigger > Input Channels > Read Signal > Ref 1.  

 

Figure 32: Inputs/Trigger menu setup 
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3. Press  to start the acquisition. The following figure shows the 
statistical results: 

 

Figure 33: TAA lesson: statistical results 

Saving the Results to a Data Log File 

To save the measurement results to a data log file, follow these steps: 

1. Go to the Log menu in the menu bar and select Statistics.  

Display an example of the default application directory and log file name.  

2. Select Logging On. 

3. Press  to start the acquisition. 

4. Select Logging Off before viewing the data log file. 

5. Exit the application. 
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Viewing a Data Log File 

To view the data log file in a text editing application, such as Wordpad, follow 
these steps: 

1. From the tool bar, select Start icon > Programs > Accessories > Wordpad. 

2. Select File > Open. 

3. Locate the C:\TekApplications\tdsddm2\data directory. 

4. Select All Documents (*.*) for the Files of Type. The following figure 
displays the Log file with default file name.  

 

Figure 34: Log file with default file name 
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5. Select the TAA.csv file and Open. The following figure displays an example 
of TAA.csv file viewed in Wordpad. 

 

Figure 35: TAA.csv file viewed in Wordpad 

You can also import the .csv file to a DOS-based personal computer and then 
view the data log file with a spreadsheet, database, or data analysis program.  
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Stopping the Tutorial 

If you need more than one session to complete the tutorial lessons, you can stop 
the tutorial and return to it another time.  

To save the application setup and stop your session, refer to Saving a Setup. 

Returning to the Tutorial 

To return to the tutorial setup, you can start the application and then recall the 
saved setup. To recall the application setup, refer to Recalling a Saved Setup. 
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Application Examples 

This section presents many application examples. The simplified examples 
highlight the application measurements and give you ideas on how to use the 
application to solve your own test problems. 

 Measuring TAA 

 Measuring PW50 

 Measuring Asperity 

 Measuring Overwrite 

 Measuring Resolution 

 Measuring Baseline Shift 

 Measuring NLTS 

 Measuring SNR 

 Creating and viewing track profiles 

To use these examples, you must have the TDSDDM2 application installed and 
enabled on the oscilloscope, the probes connected to your disk drive system 
under test (SUT), and the configuration tasks performed as needed for your SUT. 
For information, see Installation procedures and Configuring the application.  

Note: Figures that show the display of an oscilloscope are from a TDS7104; 
there may me minor differences if you are using another type of oscilloscope. 
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The application includes waveform files that you can recall to a reference 
memory to try out each example in this section. The following table lists the 
waveform file names and corresponding measurements. 

Table 20: Waveform files and application examples 
File name Measurement
taapw50.wfm TAA and PW50
ovlosig.wfm and ovhisig.wfm Overwrite
baselineShift.wfm Baseline Shift
asperity.wfm Asperity
x9x4x1.wfm NLTS and SNR

 

Configuring a Measurement 

You can configure any measurement to help you analyze measurement results. 
The application includes the following possible configurations: 

 Specifying a Range of Sectors  

 Specifying a Limit Test  

 Specifying Gating  

 Specifying hysteresis  

 Specifying a Filter  

Specifying a Range of Sectors 

To specify a range of sectors from which to take measurements, follow these 
steps: 

1. Select Inputs > Inputs/Trigger > Trigger Mode > Sector. 

2. Select Start Sector > (number). 

3. Select Stop Sector > (number). 

4. Set the Preamble option. Use the multipurpose knob, and select a value that 
is greater than the actual signal preamble duration. This ensures that the 
preamble is not acquired and is not included in the measurement. 
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Specifying a Limit Test 

To use limit testing to include a pass/fail measurement result, follow these steps: 

1. Select Limit Test On. 

2. Use the multipurpose knob to set a value for the Upper Limit option that is 
appropriate for your SUT. View Entry Methods menu showing multipurpose 
knob.  

3. Use the multipurpose knob to set a value for the Lower Limit option that is 
appropriate for your SUT. 

The Asperity measurement does not need to test limits. 

Specifying Gating 

Instead of measuring around the entire track, you can use cursor gating to 
localize the measurement. To specify gating, follow these steps: 

1. Select Inputs > General > Gating On. 

2. In the oscilloscope program, position the cursors to bind the part (on either 
side) of the waveform that you want to measure. 

3. Select App to return to the application. 

Specifying Hysteresis 

You can use the Hysteresis option to avoid identifying noise as actual signals.  

To specify hysteresis, select Inputs/General > Hysteresis and use the 
multipurpose knob to set a value for the Hysteresis option that is appropriate for 
your SUT. 

The hysteresis value, in divisions, is reflected above and below the waveform 
baseline. For example, if you choose a value of 1.5 divs, the hysteresis level 
ranges from -1.5 divs to +1.5 divs. 

Specifying a Filter 

You can modify the Read Signal input by applying filters that block specific 
frequency bands. 
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Using Reference Waveforms 

To attain the results shown in each figure (except for Track Profile) from the 
specified .wfm file, you need to define the following general setup: 

1. In the oscilloscope menu bar, select File> Recall Default Setup. 

2. Recall the appropriate .wfm file to one of the reference memories; refer to 
Display reference waveform files directory.  

3. Select Measurements > Save/Recall > Recall default values. 

4. Select the appropriate measurement from either the TAA/PW50 or 
NLTS/Other Measurements menus. 

5. Select the reference memory as the Read Signal input option in the 
Inputs/Trigger menu. Refer to the example of TAA measurement results 
based on the taapw50.wfm file. 

Measuring TAA 

In this example, you can measure the track average amplitude (TAA). To take a 
TAA measurement, follow these steps: 

1. Select Measurements > TAA/PW50 > TAA. 

2. To configure the measurement, refer to Configuring a Measurement. 

3. Set the Sequence Mode to Single or Free Run. 

4. Select  to start the measurement.  

5. When the measurement is complete, the statistical results automatically 
display.  

Measuring PW50 

In this example, you can measure the pulse width at 50% (PW50). To take a 
PW50 measurement, follow these steps: 

1. Select Measurements > TAA/PW50 > PW50. 

2. To configure the measurement, refer to Configuring a Measurement.  

3. Set the Sequence Mode to Single or Free Run. 
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4. Select  to start the measurement.  

5. When the measurement is complete, the statistical results automatically 
display. The following figure shows an example of PW50 measurement 
results based on the taapw50.wfm file.  

 

Figure 36: PW50 measurement results example 
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Measuring Asperity 

In this example, the oscilloscope will detect asperities. To take an Asperity 
measurement, follow these steps: 

1. Select Measurements > NLTS/Other > Asperity.  

2. Use the multipurpose knob to set a value for the Threshold option that is 
appropriate for your SUT. The recommended initial setting is at least twice 
the peak value of the signal. If the signal crosses this level, it is counted as 
an asperity. No additional asperities are counted until the signal crosses zero 
volts again. 

3. If you want to change trigger settings or localize the measurement, do so 
now. The application defaults to the settings specified in the Trigger menu. 
For further information, refer to Setting Up the Application Trigger. 

4. Set the Sequence Mode to Single. 

5. Select  to start the measurement.  
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6. When the measurement is complete, a list of asperities, sector locations and 
time locations automatically display. The following figure shows an 
example of Asperity measurement results based on the asperity.wfm file.  

 

Figure 37: Asperity measurement results example 

Note: To attain these results from the asperity.wfm file, in addition to the general 
procedure, you need to define the Asperity Threshold as 1.5 V. 
 



 
 
Application Examples 
 

62 TDSDDM2 Disk Drive Measurements Application
 

Measuring Overwrite 

In this example, you can measure the overwrite amount of residual signal 
remaining from a previous write when new data is written to the same location. 
The application overwrites part of the disk drive to take this measurement.  

To measure the overwrite, you will also need a personal computer.  

Note: Select a record length on the oscilloscope of 5,000 or more for Overwrite 
measurements. This increases the frequency and the measurement resolution. 
 

To take an Overwrite measurement, follow these steps: 

1. Erase the track by using a permanent magnet or using the PC to perform a 
DC erase for many revolutions on a three-band track of overlapping tracks 
centered on the specified radius. 

2. Write a low-frequency data pattern of isolated pulses to the track.  

To try out this example, recall the ovlosig.wfm file to a reference memory. 

3. Select Measurements > NLTS/Other > Overwrt. 

4. Set the Sequence Mode to Single or Free Run.  

5. Select  to start the measurement. The application measures the 
magnitude of the signal and then pauses.  
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The Sequence Control displays Paused For Action and the results display PASS 1 
in the upper right corner. The following figure displays an example of the 
Overwrite measurement Pass 1 result based on the ovlosig.wfm file:  

 

Figure 38: Overwrite measurement, PASS 1 example 

6. Without erasing the previous data, overwrite the track with a high-frequency 
data pattern.  

If you are trying out this example, you can overwrite the ovlosig.wfm file 
with the ovhisig.wfm file. To do this, recall the ovhisig.wfm file to the same 
reference memory used for the ovlosig.wfm file. 

7. Select  to continue. The results display PASS 2 in the upper right 
corner.  

When the measurement is complete, the statistical results automatically 
display.  
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The following figure displays an example of the Overwrite measurement Pass 2 
results based on the ovlosig.wfm and ovhisig.wfm files: 

 

Figure 39: Overwrite measurement results, PASS 2 example 
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Measuring Resolution 

In this example, you can measure the resolution of a head and disk combination. 
The application determines the ratio of two TAA measurements of a low-
frequency pattern to a high-frequency pattern. The result is a percentage.  

Note: To measure the resolution, you will also need a personal computer. 
 

To take a Resolution measurement, follow these steps: 

1. Erase the track by using a permanent magnet or using the PC to perform a 
DC erase for many revolutions on a three-band track of overlapping tracks 
centered on the specified radius. 

2. Use the PC to write a high-frequency data pattern of isolated pulses to the 
disk.  

3. Select Measurements > NLTS/Other > Resltn. 

4. Set the Sequence Mode to Single. 

5. Select  to start the measurement. The oscilloscope performs a TAA 
measurement of the high-frequency pattern and then pauses. 

6. The Sequence Control displays Paused For Action and the results display 
PASS 1 in the upper right corner.  

7. Erase the track again as described in step 1. 

8. Use the PC to write a low-frequency data pattern of isolated pulses to the 
disk.  

9. Select  to continue. The results display PASS 2 in the upper right 
corner.  

10. When the measurement is complete, the statistical results automatically 
display.  

An example is not included because it is similar to the Overwrite measurement. 
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Measuring Baseline Shift 

In this example, you will measure the difference between the baseline of a 
positive pulse and the baseline of a negative pulse. To take a Baseline Shift 
measurement, follow these steps: 

1. Select Measurements > NLTS/Other > Baseline Shift. 

2. Set the Sequence Mode to Single or Free Run. 

3. Select  to start the measurement.  

4. When the measurement is complete, the statistical results automatically 
display. Figure 2-39 shows an example of a Baseline Shift measurement 
results based on the baseline.wfm file. The following figure displays the 
Baseline Shift measurement results example.  

 

Figure 40: Baseline Shift measurement results example 
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 Measuring NLTS 

To take NLTS measurements, your setup must meet the following requirements: 

 The waveform selected for the measurement must correspond to a bit pattern 
written on the disk generated using a valid (maximum length) polynomial; 
among other things, this might require that you disable RLL encoding. 

 The disk drive waveform must have at least 1,000 samples. 

 There must be at least eight samples per bit. 

 The oscilloscope must acquire at least three periods of the pattern where the 
period is the amount of time before the pseudo-random bit pattern begins to 
repeat itself; to do this depends on the sample rate of the oscilloscope, the 
estimated value that you enter for the Pattern Dur option, and the number of 
bits per period (based on the polynominal used). 

To take an NLTS measurement, follow these steps: 

1. Select Measurements > NLTS/Other > NLTS Initial. 

2. Select Pattern Dur and specify a value. 

The pattern duration is the length of time of the period of a pseudo-random 
data pattern in the readback signal. The pattern duration can be an estimate, 
as long as the estimate is within the tolerance that you specify in step 3; the 
application will measure the exact duration of the pattern. (Due to variations 
in revolution speed between disk drives, specifying the pattern duration is 
necessarily an estimate.) 

3. Select Dur Toler and specify the tolerance of your pattern duration estimate 
(up to 30%). Using a tighter tolerance reduces measurement time. 

Note: If you know the exact duration of the data pattern, you can reduce the 
measurement time by specifying a Duration Tolerance of 0%. The application 
will use the Pattern Duration that you specify without attempting to adjust to the 
actual duration of the pseudo-random pattern. 
 

4. Select Poly Index and use the multipurpose knob to specify the pseudo- 
random binary sequence polynomial. This should be the same polynomial 
used to generate the data pattern written to the media.  

For valid results, it is essential that you specify the same polynominial as the 
one used for recording data on the hard disk (media). Both polynomials 
must be valid according to the 1995 IDEMA “white paper.” 
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The NLTS measurement is based on autocorrelation and uses a polynomial 
to generate a pseudo-noise sequence. Select the polynomial using the 
multipurpose knob; all selections provide a valid pseudo-noise sequence. 
(The application removes invalid polynomials from the selection set.) The 
polynomial index value on the scale is a condensed notation of the selected 
polynomial, obtainable by making x=2. For example: 

 
5. If you want to change trigger settings or localize the measurement, do so 

now. The application defaults to the settings specified in the Trigger menu. 
For further information, refer to Setting Up the Application Trigger.  

6. Set the Sequence Mode to Single or Free Run. 

7. Press  to start the acquisition.  
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8. When the measurement is complete, the statistical results automatically 
display. The following figure displays an example of NLTS Initial 
measurement results based on the x9x4x1.wfm file.  

 

 

Figure 41: NLTS measurement results example 
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Measuring SNR 

To take SNR measurements, your setup must meet the following requirements: 

 The disk drive waveform must have at least 1,000 samples 

 There must be at least eight samples per bit 

 The oscilloscope must acquire at least three periods of the pattern where the 
period is the amount of time before the pseudo-random bit pattern begins to 
repeat itself; to do this depends on the sample rate of the oscilloscope, the 
estimated value that you enter for the Pattern Dur option, and the number of 
bits per period  

To take an SNR measurement, follow these steps: 

1. Select Measurements > NLTS/Other > SNR. 

2. Select Pattern Dur and specify a value. 

The pattern duration is the length of time of the period of a pseudo-random 
pattern in the readback signal. The pattern duration can be an estimate, as 
long as the estimate is within the tolerance that you specify in step 3; the 
application will measure the exact duration of the pattern. (Due to variations 
in revolution speed between disk drives, specifying the pattern duration is 
necessarily an estimate.) 

3. Select Dur Toler and specify the tolerance of your pattern duration estimate 
(up to 30%). Using a tighter tolerance reduces measurement time. 

Note: If you know the exact duration of the data pattern, you can reduce the 
measurement time by specifying a Duration Tolerance of 0%. The application 
will use the Pattern Duration that you specify without attempting to adjust to the 
actual duration of the pseudo-random pattern. 
 

4. Select Bits/Pattern and specify a value. 

Periodic signals used for the SNR measurement are isolated low-density 
periodic transitions (low frequency), isolated high-density periodic 
transitions (high frequency), or patterned data such as pseudo-random 
sequences. 

 If you are using a high-frequency pattern consisting of constantly spaced 
isolated transitions, use two bits per pattern for the low frequency and high 
frequency patterns.  

 For general patterned data, use the number of bits per pattern period, 
depending on what was previously recorded on the disk.  
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 For pseudo-random data of pseudo-noise type generated with shift registers 
(pseudo-random binary sequence), the number of bits per pattern is 2L - 1, 
where L is the order of the characteristic polynomial. For example, for a 9th 
order polynomial the value would be ; for a 7th order polynomial 
the value would be . 

5. If you want to change trigger settings or localize the measurement, do so 
now. The application defaults to the settings specified in the Trigger menu. 
For further information, refer to Setting Up the Application Trigger.  

6. Set the Sequence Mode to Single. 

7. Press  to start the acquisition.  

8. When the measurement is complete, the statistical results automatically 
display.  
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The following figure displays an example of SNR measurement results based on 
the x9x4x1.wfm file. 

 

Figure 42: SNR measurement results example 
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Creating and Viewing Track Profile Plots 

Track Profile plots are reference memory waveforms that contain a history of 
measurement results. You can use track profiles to observe sector-to-sector 
variations in measurements and to identify the location of flaws within a track. 

Note: The result of creating a Track Profile plot from a reference waveform is a 
short straight line. 
 

To create and view a Track Profile plot, follow these steps: 

1. Select a measurement from either the TAA/PW50 or NLTS/Other 
Measurements menus. 

2. To configure the measurement, refer to Measurement Configurations. 

3. Select Inputs > General > Gating Off. 

4. Select Plot > Track Profile > Store Profile In: > any reference memory. 

Note: As soon as you select Plot> Track Profile> On, the application deletes all 
information contained in the selected reference memory. 
 

5. Select Plot > Track Profile > On. 

6. Set the Sequence Mode to Single or Free Run. 

7. Select  to start the measurement. The measurement results are saved 
as statistics and are stored as a track profile plot in the reference memory 
selected in step 4. 
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The following figure displays an example of a Track Profile plot from a TAA 
measurement.  

 

 

Figure 43: Track Profile plot example 

8. If you use the Sector Trigger mode, you can also use the vertical cursors on 
the oscilloscope. To use the vertical cursors, press the Cursors front-panel 
button. The default Cursor Type is V Bars.  

9. Select App to return to the application.  

You can view the results of each execution of the measurement algorithm by 
moving the cursor along the Track Profile plot. The Value at Cursor and Sector at 
Cursor readouts show the measurement results at the current location of the 
cursor. The Value at Cursor is in units relative to the measurement (V, MHz, 
dBs). 

Note: The readout values are available only with current Track Profile plots; 
they are not available with waveforms that are recalled from reference memory. 
You also must select the Sector Trigger mode to use cursors with track profiles. 
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The following figure displays an example Track Profile plot with cursors: 

 

Figure 44: Track Profile plot example with cursors 

10. To save the reference waveform containing the plot, follow these steps:  

f. Go to the File menu in the menu bar of the oscilloscope and access 
Reference Waveforms > Reference Setup.  

g. Select the appropriate Ref tab and Save Wfm to File.  

11. To clear the Track Profile plot, select Reset. 
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GPIB Program Example 

This section contains an example of a GPIB program that can execute the 
TDSDDM2 application. The oscilloscope hard disk and optional applications 
compact disc both contain this program in the ddm2ctrl.c file. The file resides on 
the hard drive in the C:\Program Files\TekApplications\tdsddm2 directory. 

This example shows how a GPIB program might execute the application to do 
the following tasks: 

 Start the application 

 Select a measurement 

 Select an input 

 Define a waveform 

 Enable the logger 

 Take a measurement 

 Check for an error 

 Exit the application 

Guidelines 

Your GPIB program should comply with the following guidelines: 

 The application startup must complete before sending additional GPIB 
commands to the application (see example). 

 The measurements cycle must complete before data is queried (see 
example). 

 The error variable should be checked to ensure that an error has not occurred 
because of a measurement command problem. 
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GPIB Program Example 

/* C Program Example: TDSDDM2 GPIB control      */  

/* ====================================================================  

 * This sample program is for Tektronix Java application TDSDDM2 --  

 * Disk Drive Measurements  

 *  

 * Note1: In order to build the .exe correctly, copy gpib-32.obj from  

 * ”C:\Program Files\National Instruments\GPIB\NI488\LangInt\C\” or  

 * ”C:\Program Files\GPIB-NT\LangInt\C\ to  

 * the workspace.  

 *  

 */  

   

 #include <string.h>  

 #include <stdio.h>  

 #include <sys/timeb.h>  

 #include <windows.h>  

 #include ”C:\GPIB-NT\LangInt\C\decl-32.h”  

 

 int start_application(/* in */ int scope);  

 int do_single_test(/* in */ int scope);  

 

 

 void main (void)  

 {  

  char read_buffer  [100] = ””;  

  char write_buffer [100] = ””;  

  int  scope;  

  int  status;  

   

  /*  

   * Open session for IBIC  

   */  

  scope = ibfind (”DEV2”);  

  status = ibpad (scope, 1);  

  status = ibtmo (scope, T10s);  

 

  status = ibwrt (scope, write_buffer, strlen (write_buffer));  

 

 

  /*  

   * Start Application  

   */  

  if (start_application(scope)){  

   printf (”Application is started up!\n”);  

 

   /*  

    * Turn on a measurement (TAA)  

    */  

   sprintf (write_buffer, ”%s”, ”Variable:value \”measurement\”,\”TAA\””);  

   status = ibwrt (scope, write_buffer, strlen (write_buffer));  
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   /*  

    * Select Source Type -- REF  

    */  

   sprintf (write_buffer, ”%s”, ”Variable:value \”readSignal\”, \”Ref1\””);  

   status = ibwrt (scope, write_buffer, strlen (write_buffer));  

   

 

   /*  

    * Recall Waveform to Ref  

    */  

   sprintf (write_buffer, ”%s”, ”recall:waveform 

    \”c:\\TekApplications\\tdsddm2\\waveforms\\diskdrive.wfm\”, REF1”); 

 

   status = ibwrt (scope, write_buffer, strlen (write_buffer));  

    

    

   /*  

    * Display Ref1  

    */  

   sprintf (write_buffer, ”%s”, ”select:ref1 on”);  

   status = ibwrt (scope, write_buffer, strlen (write_buffer));  

    

 

   /*  

    * Turn on Log Statistics for TAA measurement  

    */  

   sprintf (write_buffer, ”%s”, ”Variable:value \”TAAloggerState\”,\”On\””);  

   status = ibwrt (scope, write_buffer, strlen (write_buffer));  

   /*A Timer is needed after setting the loggerState on*/  

  Sleep(2000);  

 

 

   /*  

    * Do a single test  

    */  

    

   if (do_single_test(scope)){  

 

     /*  

      * Set Measurement for which you want to query test result -- TAA  

      */  

     sprintf (write_buffer, ”%s”, ”Variable:value \”resultFor\”, 

\”TAA\””);  

     status = ibwrt (scope, write_buffer, strlen (write_buffer));  

 

      

     /*A Timer is needed after setting the measurement to be queried*/  

     Sleep(500);  

     /*  

      * Query mean result  
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      */  

     sprintf (write_buffer, ”%s”, ”Variable:value? \”mean\””);  

     status = ibwrt (scope, write_buffer, strlen (write_buffer));  

     status = ibrd (scope, read_buffer, sizeof (read_buffer));  

 

     if (ibcnt != 3) {      /* It’s 

not an empty string */  

      read_buffer [ibcnt] = 0; /* Get rid of extra 

characters */  

      printf (”Mean TAA = ”);  

      printf (”%s”, read_buffer);  

      }  

     }  

   else  

      printf (”*** Fail to query result ***\n”);  

       

       

   

  }  

  else{  

   printf (”*** Fail to start Application ***\n”);  

   return;  

  }  

 

  /*  

   * Display Off for Ref1 before exiting  

   */  

  sprintf (write_buffer, ”%s”, ”select:ref1 off”);  

  status = ibwrt (scope, write_buffer, strlen (write_buffer));  

 

 

  /*  

   * Exit application  

   */  

  printf (”Exit application!\n”);  

  sprintf (write_buffer, ”%s”, ”Variable:value \”application\”,\”exit\””);  

  status = ibwrt (scope, write_buffer, strlen (write_buffer));  

 

 

  /*  

   * Program Ending  

   */  

  printf (”Program Terminating Normally\n\n”);  

 

  return;  

   

 }  

 

/*--------------------------------------------------------------------------  

 * Function: start_application  

 * Argument: scope  

 * Return: 1 if success, 0 otherwise  

 *  
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 * This function starts the application and comfirms the completion of startup  

 */  

 int start_application(/* in */ int scope)  

 {  

  char read_buffer  [100];  

  char write_buffer [100];  

  char app_name[30] = ”\”tdsddm2\”\n”;  

  int  status;  

  int  timer = 0;  

  int  i = 0;  

 

  /*  

   * Has application already been started?  

   */  

  sprintf (write_buffer, ”%s”, ”Variable:value? \”application\””);  

  status = ibwrt (scope, write_buffer, strlen (write_buffer));  

  status = ibrd (scope, read_buffer, sizeof (read_buffer));  

  read_buffer [ibcnt] = 0; /* Get rid of extra characters */  

   

  if (strcmp(app_name, read_buffer) == 0){  

   return 1;      /* Application is running, 

don’t need to do anything */  

  }  

 

  /*  

   * If application is not started up, start it and wait for application to completely  

   * start up  

   */  

 

  sprintf (write_buffer, ”%s”, ”Application:activate \”Disk Drive Measurements V2\””);  

  status = ibwrt (scope, write_buffer, strlen (write_buffer));  

 printf (”Starting application, please wait...\n”);  

  while (strcmp(app_name, read_buffer) != 0){  

   timer = timer + 2;  

   if (timer > 45) {   /* The application normally take 24 seconds 

to start up */  

     printf (”***Application start up time out***\n”);  

     return 0;    /* Something is wrong if 

application does not start up in 30s */ 

 

   }  

   sprintf (write_buffer, ”%s”, ”Variable:value? \”application\””);  

   status = ibwrt (scope, write_buffer, strlen (write_buffer));  

   status = ibrd (scope, read_buffer, sizeof (read_buffer));  

   read_buffer [ibcnt] = 0;/* Get rid of extra characters */  

  Sleep(2000);  

 

 

 

  }  

  /* Application start up! */  
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  return 1;  

 }  

 

/*--------------------------------------------------------------------------  

 * Function: do_single_test  

 * Argument: scope  

 * Return: 1 if success, 0 otherwise  

 *  

 * This function does a single measurement  

 */  

 int do_single_test(/* in */ int scope)  

 {  

  char read_buffer  [100];  

  char write_buffer [100];  

  char state[10]   = ”\”Ready\”\n”;  

  int  status;  

  int  timer = 0;  

  int  i = 0;  

   

  /*  

   * Start measurement  

   */  

 printf (”Do a single test...\n”);  

  sprintf (write_buffer, ”%s”, ”Variable:value \”sequencerState\”,\”Sequencing\””);  

  status = ibwrt (scope, write_buffer, strlen (write_buffer));  

 

 do{  

   timer = timer + 2;  

   if (timer > 60) { /* Assuming a single test takes less than 60 seconds */  

     printf (”***Test time out***\n”);  

     return 0;   /* Something is wrong if 

sequencerState does not come back  

           * to Ready */  

   }        

   sprintf (write_buffer, ”%s”, ”Variable:value? \”sequencerState\””);  

   status = ibwrt (scope, write_buffer, strlen (write_buffer));  

   status = ibrd (scope, read_buffer, sizeof (read_buffer));  

   read_buffer [ibcnt] = 0;/* Get rid of extra characters */  

  Sleep(2000);  

  }while (strcmp(state, read_buffer) != 0);  

 

 

  return 1;  

 }  
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Parameters 

This section describes the TDSDDM2 application parameters, and includes the 
menu default settings. You should refer to the user manual for your oscilloscope 
for operating details of other controls, such as front-panel buttons.  

The parameters for the menus and options list the selections or range of values 
available for each and also includes the default values. 

Refer to the GPIB Programming section of this Help file for a complete list of 
the GPIB Command Syntax. This entry includes a complete list of the GPIB 
commands along with the arguments, variables, and variable values that 
correspond to the TDSDDM2 parameters. 

Note: Incremental unit values shown are valid when the FINE button is enabled 
on the oscilloscope. 
 

Measurements Menus 

There are four choices on the Measurements menu: TAA/PW50, NLTS/Other, 
Save/Recall, Minimize. 

TAA/PW50 Menu 

The options in the TAA/PW50 Measurements menu are: 

 TAA, default 

 TAA+ 

 TAA- 

 TAA Snapshot 

 PW50 

 PW50+ 

 PW50- 

 PW50 snapshot 

The following table lists the TAA/PW50 Limit Test Area Parameters 
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Table 21: TAA/PW50 Limit Test area parameters  
Measurement Option Selections Default

setting
All On/Off On, Off On
TAA, TAA+, TAA
Snapshot

Upper Limit
Lower Limit

0 Vpp to 10.0 Vpp in units of 1 mVpp
0 Vpp to 10.0 Vpp in units of 1 mVpp

10.0 Vpp
0.0 Vpp

TAA- Upper Limit
Lower Limit

-10.0 Vpp to 0 Vpp in units of 1 mVpp
-10.0 Vpp to 0 Vpp in units of 1 mVpp

0.0 Vpp
-10.0 Vpp

PW50, PW50+, PW50-
, PW50 Snapshot

Upper Limit
Lower Limit

 0 s to 1.0 s in units of 50 ps
 0 s to 1.0 s in units of 50 ps

1.0 s
0 s

 

NLTS/Other Menu 

The options in the TAA/PW50 Measurements menu are: 

 TAA, default 

 TAA+ 

 TAA-- 

 TAA Snapshot 

 PW50 

 PW50+ 

 PW50-- 

 PW50 snapshot 
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The following table lists the NLTS/Other Limit Test Area Parameters: 

Table 22: NLTS/Other Limit Test area parameters 
Measurement Option Selections Default setting
All* On/Off On, Off On
NLTS Initial, NLTS 1st
Adj, NLTS 2nd Adj,
NLTS Snapshot

Upper Limit
Lower Limit

-100% to 100% in units of 0.1%
-100% to 100% in units of 0.1%

100%
-100%

SNR Upper Limit
Lower Limit

-20.0 dB to 100 dB in units of 0.1 dB
-20.0 dB to 100 dB in units of 0.1 dB

100.0 dB
-20.0 dB

Baseline Shift Upper Limit
Lower Limit

-5.0 Vpp to 10.0 Vpp in units of 1 mVpp
-5.0 Vpp to 10.0 Vpp in units of 1 mVpp

10.0 Vpp
0.0 Vpp

Overwrt Upper Limit
Lower Limit

0 dB to 100 dB in units of 0.01 dB
0 dB to 100 dB in units of 0.01 dB

100.0 dB
0.0 dB

Resltn Upper Limit
Lower Limit

0.1% to 200% in units of 0.1%
0.1% to 200% in units of 0.1%

200%
100m%

*There is no Limit Test area for the Asperity measurement.
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The following table lists the NLTS Parameters Area: 

Table 23: NLTS Parameters area  

Option Selections Default setting
Patten Dur 1.0 ns to 1.0 ms in units of 1.0 ns 9.922 µs
Dur Toler 0% to 30% in units of %1 5%
Bits/Pattern 1 to 8191 511

 
The following table lists the SNR Parameters Area: 

Table 24: SNR Parameters area 
Option Selections Default setting
Patten Dur 1.0 ns to 1.0 ms in units of 1.0 ns 9.922 µs
Dur Toler 0% to 30% in units of %1 5%
Bits/Pattern 1 to 8191 511

 
The following table lists the Asperity Parameters Area: 

Table 25: Asperity Parameters area  
Option Selections Default setting
Threshold 0.0 V to 10.0 V in units of 10 mV 2.0 V

 
The following table lists the Save/Recall Menu Parameters: 

Table 26: Save/Recall Measurements menu parameters  
Option Selections Default setting
Save None C:\TekApplications\tdsddm2\setups\setup1.ini
Recall None C:\TekApplications\tdsddm2\setups\setup1.ini
Default None

 
There are no parameters for the Minimize function. 

 
 

 

 

 



 
 

Parameters 
 

TDSDDM2 Disk Drive Measurements Application 
 
 

87

Input Menus 

There are three Inputs menus: Inputs/Trigger, Inputs Filter, and Inputs General. 

Inputs/Trigger menu 

The following table lists the parameters for the Input Channels area and the 
selections available for each: 

Table 27: Input Channels area parameters 
Option Selections Default setting
Read Signal Ch 1, Ch 2, Ch 3, Ch 4, Ref 1, Ref 2, Ref 3,

Ref 4, Math1, Math 2, Math 3, Math 4
Ch 1

Read Gate Ch 1, Ch 2, Ch 3, Ch 4 Ch 2
Sector Pulse Ch 1, Ch 2, Ch 3, Ch 4 Ch 3
Index Pulse Ch 1, Ch 2, Ch 3, Ch 4 Ch 4

 

Trigger Area Parameters 

The following table lists the parameters for the trigger Area available for each: 

Table 28: Trigger area parameters 

Option Selections Default
setting

Mode Sector, Read Gate*, User*, Index* User
Preamble** 0 to 250.0 s in units of 1.0 ns 1.0 µs
Start Sector** 1 to 1000 in units of 1 sector 1
Stop Sector** 1 to 1000 in units of 1 sector 1
*    Refer to Setting Up the Oscilloscope Trigger and to Setting Up the
Application Trigger.
**   Only available when Sector is the trigger mode (See Trigger Options.)
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Inputs/Filters Menu 

The following table lists the parameters for the Inputs/Filters Menu for each: 

Table 29: Filter 1 and Filter 2 areas parameters 

Option Selections Default setting
On/Off On, Off Off
Cutoff Freq 5% to 35% of the Sample Rate
Update None
Type Lowpass, Highpass Lowpass, Filter 1

Highpass, Filter 2
Slope 12 dB/oct, 24 dB/oct, 36 dB/oct, 48 dB/oct,

60 dB/oct, 72 dB/oct, 84 dB/oct
24 dB/oct

Store In None, Ref 1, Ref 2, Ref 3, Ref 4 Filter 1 in Ref 3
Filter 2 in Ref 4

 

Inputs General Menu 

The following table lists the parameters for the Inputs General Menu for each: 

Table 30: General menu parameters 

Option Selections Default setting
Hysteresis 0.1 divs to 5.0 divs in units of 0.1 divs 0.8 divs
Gating On, Off Off
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View Menu 

There are no parameters for the View Results menu. 

Plot Track Profile Menu 

The following table lists the parameters for the Plot Track Profile Menu for each: 

Table 31: Plot Track Profile menu parameters 
Option Selections Default setting
On/Off On, Off Off
Store Profile In: Ref1, Ref2, Ref3, Ref4 Ref1
Reset None

 

Log Statistics Menus 

The following table lists the parameters for the Log Statistics Menu for each: 

Table 32: Log Statistics menu parameters 
Option Selection Default setting
Logging On, Off Off
Clear None
Save
Current

None

Log File
Name:
Browse

Any file C:\TekApplications\tdsddm2\data\<measurement> csv

 

Help Menu 

There are no parameters for the Help menu. 
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Sequence Control Menu 

Table 33:Sequence Control menu parameters 
Parameter Selections Default setting
Mode Single, Free Run Single
Start (or Continue) None
Pause None
Stop None
Reset None
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Appendix A: Measurement Algorithms 

TDSDDM2 performs disk drive measurements. This section contains information 
about the algorithms used by the application to execute each measurement. 

Unless specifically stated otherwise, all measurements in the Disk Drive 
Measurements Application are conducted in accordance with procedures 
specified in the International Disk Drive Equipment and Materials Association 
(IDEMA) Disk Drive Standard. 

Note: Refer to the Applications Examples section for information on how to 
perform each measurement. Each example includes a detailed procedure. 
 

Oscilloscope Setup Guidelines 

For all measurements, use the following guidelines to set up the oscilloscope: 

 The signal is any channel, reference, or math waveform. 

 The vertical scale for the waveform must be set so that the waveform does 
not exceed the vertical range of the TDS oscilloscope. 

 The time per division must be set small enough to capture sufficient 
waveform detail and avoid aliasing. 

 Use a differential probe on the Read channel signal to reject noise and 
remove DC bias. 

Calculating Statistics 

The application calculates statistics for each selected measurement, and logs the 
statistics on a cycle-cycle basis in a fairly large waveform. The standard statistics 
are for the Maximum, Minimum, Mean, Standard Deviation, and Population. 

The application continues to calculate statistics until you press the Reset button 
in the Sequence Control menu. This resets all values to zero. 

  

The application calculates this statistic using the following equation: 

Max X = Highest value of X 

The application calculates this statistic using the following equation: 
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Min X= Lowest value of X 

The application calculates this statistic using the following equation: 

 
It may seem odd that the equation for the estimate of the Standard Deviation 
contains a 1/(N-1) scaling factor. If you knew the true mean of X and used it in 
place of the estimated mean, , then you would, in fact, scale by 1/N. But,  
is an estimate and is likely to be in error (or bias), causing the estimate of the 
Standard Deviation to be too small if scaled by 1/N. This is the reason for the 
scaling shown in the equation. (Refer to Chapter 9.2 in A. Papoulis, Probability, 
Random Variables, and Stochastic Processes, McGraw Hill, 1991.) 

The application calculates this statistic using the following equation: 
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TAA Measurements 

The application calculates this measurement using the following equation: 

 
Where:  N is the number of positive and negative pulse pairs 

  Vpp is the peak-to-peak voltage  
The application performs the measurement according to the following algorithm: 

1. Find all of the peak-to-trough pairs in the data area to be measured. 

Find the peak by searching from the first crossing of the signal above the positive 
hysteresis level to the crossing of the signal below the negative hysteresis level. 
(See figure below.) Keep the maximum value over this range. Take one sample 
on either side of the maximum value and average the three values to obtain the 
positive peak value. This is done to remove noise bias, which would otherwise 
occur. 

2. Search the range from the negative hysteresis crossing to the next positive 
hysteresis crossing; keep the minimum value. Take one sample on either 
side of the minimum value and average the three values to obtain the 
negative peak value. 

3. Average all measured peak-to-peak values. The result is the TAA value.  
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The following figure shows how a TAA measurement is defined. 

 

Figure 45: TAA measurement 

About PW50 Measurements 

The PW50 measurement is the average pulse width at 50% of the pulse peak of a 
group of both positive and negative pulses. Peaks and troughs are measured. The 
baseline reference for measuring the peak or trough is zero volts. The figure 
below shows the definition of a pulse width at 50%. 

 

 

Figure 46: Pulse width at 50% 

The application calculates this measurement using the following equation: 
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Where: N is the number of positive and negative pulse pairs 

          PW is the pulse width at 50% 

The application performs the measurement according to the following algorithm: 

1. Set the disk drive to the specified speed. 

2. Position the head to the desired gap, radius, and skew angle. 

3. Precondition the media service. (See the IDEMA standard, document T3–
91, for information about preconditioning the media service.) 

4. Write the specified frequency at the specified current for one revolution of 
the disk. 

5. Measure the peak-to-peak analog amplitude of the Read Signal for one 
entire revolution, excluding all nonuniform segments, such as write splices, 
servo gaps, and header fields. Uses the hysteresis value when looking for 
peaks. 

6. Compute the track average amplitude around the entire track by summing up 
the peak-to-peak voltages of each plus and minus pulse pair. Divide the 
result by the number of pulse pairs. 

7. Perform the measurement by acquiring one segment at a time, measuring it, 
and combining all the results for the final value. To speed up the 
measurement process, you can specify a smaller region of each track 
segment to measure by using the cursors gating or by decreasing the record 
length. 

This measurement requires you to specify the number of segments on the 
track to be tested. 

8. Use a value of 1/2 of the TAA value as the threshold level at which to 
measure the pulse width of each positive and negative pulse. Compute the 
average pulse width around the track for all pulses measured. 

9. Displays the results in the View Results menu, saves the results as a Track 
Profile plot in a reference memory, or logs the data to a file. (The results 
also display the standard deviation of the measurement for all pairs used.) 
The following figure shows the basis for these measurements. 

The pulses making up the tested group are selected by the following criteria:  

 There must be enough pulses around the recording track to provide an 
adequate statistical sample. 
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 The spacing between pulses must minimize any interaction between the 
measured pulses. 

PW50 + and PW50 - Measurements 

The PW50+ measurement is the pulse width at 50% of the peak value of the 
pulse; only peaks are measured. The PW50- measurement is the pulse width at 
50% of the trough value of the pulse; only troughs are measured.  

The application performs the measurement according to the same algorithm used 
in the PW50 measurements except only positive pulses are measured for PW50+ 
and only negative pulses are measured for PW50-. The following figure shows 
how PW50+ and PW50- measurements are defined. 

 

Figure 47: PW50+ and PW50 measurements 
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NLTS Measurements 

The NLTS measurement calculates three types of nonlinear transition shift on the 
disk drive media as follows:  

 Initial magnetization (DC erased) 

 First adjacent transition 

 Second adjacent transition 

The initial magnetization of the media can affect the position at which transitions 
(reverses in magnetization) are recorded. Initial magnetization is characterized by 
a delay in a transition, occurring when the new transition reverses the direction of 
the previous magnetization. 

The second transition in a series of consecutive transitions is called the first 
adjacent transition. The first adjacent transition is characterized as follows: when 
write data requires transitions on consecutive data bits, the latter transition is 
shifted earlier in time. In other words, when one transition in a series occurs, then 
the following transition occurs earlier than it should. 

All subsequent transitions in the series of consecutive transitions are grouped into 
the category called second adjacent transition. Second adjacent transitions are 
similar to first adjacent transitions. The difference is that the transitions are 
separated by two bit periods, not one. 

When nonlinear transition shift can be characterized, its behavior can be 
mitigated with write pre-compensation. 

There is no NLTS specification in the IDEMA standard. The NLTS measurement 
is based on a time domain cross-correlation method detailed in the IDEMA Test 
and Measurement Committee PRML Working Group Working Paper Nonlinear 
Distortion Measurement Techniques, September 1995. 



 
 
Appendix A: Measurement Algorithms 
 

98 TDSDDM2 Disk Drive Measurements Application
 

NLTS Test Methodology 

The NLTS measurement algorithm assumes that the acquired signal consists of a 
periodic signal and independent additive noise. The noise is assumed to be 
responsible for all the nonperiodic behavior of the acquired waveform.  

The application performs the measurement according to the following algorithm: 

1. Acquire three or more cycles of the pseudo-random pattern sequence read 
from the disk drive. 

2. You specify the polynomial used to generate the waveform, the approximate 
duration of one period of the periodic signal captured in the waveform, and 
the tolerance of the approximation. 

Note: The specified polynomial must generate a pseudo-noise (maximum length 
sequence, or the measurement will not proceed. 
 

3. (This step is not performed if you specify a Duration Tolerance of 0%.) 
Compute the actual cycle time and delay values. Cycle time is the period of 
time required for the pseudo-random pattern until it begins to repeats itself.  

NLTS guarantees that the real cycle time is determined by the measurement 
if your initial estimate for the cycle time is within the specified tolerance (up 
to 30%) of its real value. 

The NLTS measurement uses several cycles of the pseudo-random pattern 
waveform to improve the accuracy of the measurement, averaging over 
multiple single-waveform-cycle NLTS values.  

NLTS Initial Measurement 

The NLTS initial magnetization measurement assumes the following sequence: 

1. The medium is initially magnetized in one direction (DC-erased) 

2. Transitions that are written by a head field in the opposite direction are 

shifted later by an amount .  
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The application calculates this measurement using the following equation: 

 

Where:  is the playback voltage for a feedback channel affected by NLTS 
initial magnetization 

V(t) is the playback voltage in the absence of nonlinear effects 

T is the bit period 

 is the amount of shift 

is an integer, whose unique value is determined by the polynomial used to 
generate the recorded pseudo-noise bit sequence 

The measurement reports the nonlinear effect as a percentage of T; that is, 

Other Measurements 

The Signal-to-Noise Ratio (SNR), Asperity, Overwrite, Resolution, and Baseline 
Shift measurements perform other specialized functions. 

SNR Measurement 

The SNR measurement determines the ratio of the variance of the readback 
signal to readback noise. The measured noise consists of media noise, crosstalk, 
electronic noise, and other noise types characteristic to disk drives. Electronic 
readback noise effects can be mitigated by the averaging operation performed by 
the SNR measurement.  

Signal-to-noise ratio is defined in terms of variances of the signal and noise, and 
thus is independent of DC offsets of the readback voltage. The SNR 
measurement algorithm assumes that the acquired signal consists of a periodic 
signal and independent additive noise. The noise is assumed to be responsible for 
all the nonperiodic behavior of the acquired waveform. Noise samples are 
assumed to be independent and identically distributed.  
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The application calculates this measurement using the following equation: 

 

Where:   is the variance of the noise-free periodic signal  
 

 is the variance of the noise 

The application performs the measurement according to the following algorithm: 

1. Acquire three or more cycles of the waveform. 

2. The user specifies the number of bits in the data pattern and the duration of 
the pattern, within a known tolerance. 

3. (This step is not performed if the user specifies a Duration Tolerance of 
0%.) Compute the actual cycle time and delay values. SNR guarantees that 
the real cycle time is determined by the measurement if the initial user 
estimate for the cycle time is within the specified tolerance (up to 30%) of 
its real value.  

The SNR measurement uses several cycles of the waveform to improve the 
accuracy of the measurement, averaging over multiple single-waveform cycle 
SNR values. 

Asperity Measurement 

The Asperity measurement determines whether the head has hit a flaw in the 
media surface (a thermal asperity has occurred). When the head hits the surface 
of the media, a large voltage spike results.  
The application performs the measurement according to the following algorithm: 

1. You enter a threshold value to specify what is considered an asperity. The 
threshold needs to be set to a level greater than TAA. 

2. Begin testing for asperities, checking each peak/trough pair against the 
specified threshold. If the TAA for a peak/trough pair exceeds the threshold, 
report an asperity.  

3. Display the results: the sector number where the asperity occurred and the 
time relative to the start of the acquired data record. 
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Overwrite Measurement 

The Overwrite measurement determines the amount of residual signal remaining 
from a previous write after new data is written to the same location. The strength 
of the residual signal depends on the coercivity of the media, write current 
amplitude, and saturation characteristics of the head.  

The application calculates this measurement using the following equation: 

 

Where:  is the residual RMS amplitude 

  is the RMS amplitude 

The application performs the measurement according to the following algorithm: 

1. Erase the test track. 

2. Write data for one revolution at a low rate f1. 

3. Measure the RMS amplitude (Vo) through a narrow band filter tuned to f1. 

4. Overwrite the track with data at a high frequency f2. 

5. Measure residual RMS amplitude (Vr) at f1 again. 

6. Calculate the results. 

7. Display the results. 
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Resolution Measurement 

The Resolution measurement is a ratio of two TAA measurements: a  
low-frequency pattern to a high-frequency pattern.  

The result is expressed as a percentage. You can use this measurement to infer 
the raw write density of the disk.  

The application calculates this measurement using the following equation: 

 
Where:   is the low-frequency TAA measurement 

   is the high-frequency TAA measurement 

The application performs the measurement according to the following algorithm: 

1. Erase the test track. 

2. Write data for one revolution at a high frequency . 

3. Measure the TAA over the selected range of sectors. 

4. Erase the test track. 

5. Write the track with data at a low frequency . 

6. Measure the TAA over the selected range of sectors. 

7. Calculate the ratio of the high-frequency TAA to the low-frequency TAA. 

8. Display the results. 
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Baseline Shift Measurement 

The Baseline Shift measurement is the difference between the baseline of the 
positive pulse and the baseline of the negative pulse.  

The application calculates this measurement using the following equation: 

 
Where:  v1 is the baseline of the positive pulse 

 v2 is the baseline of the negative pulse 

The application performs the measurement according to the following algorithm: 

1. Measure the time position of a positive peak. 

2. Measure the time position of the following negative peak and the following 
positive peak. 

3. Use the peak-to-peak value (Vpp) of the Read signal and calculate the 
difference between the two baselines. 

4. Display the results. 
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Snapshot Measurements 

To see the summary measurements available for TAA, PW50, or NLTS, you can 
use the snapshot version of these measurements. The following figure displays 
examples of snapshot measurement data for the different measurements.  

 

 

 

Figure 48: Snapshot measurement data 

 

Snapshots take the following measurements: 
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 Amplitude asymmetry 

 Time asymmetry 

 Time peak-to-trough 

 Time trough-to-peak 

Amplitude Asymmetry 

The Amplitude Asymmetry measurement uses TAA values to compare the 
symmetry of the positive and negative pulses. It is available only in the TAA 
snapshot display.  
A zero value for Amplitude Asymmetry indicates that the signal is totally 
symmetric. A non-zero value indicates the percent of asymmetry of the signal. 
The range is from -100% to 100%. 
 The application calculates this measurement using the following equation: 

 
Where:  TAA+ is the mean of the calculated TAA+ measurement for a given 
sector. 

 TAA- is the mean of the calculated TAA- measurement for a given sector 

  Peak Value is the absolute value of TAA+ or the absolute value 
  of TAA- 
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Time Asymmetry 

The Time Asymmetry measurement measures the ability of the head and the 
media combination to process positive and negative transitions identically. The 
time asymmetry measurement is based on timing between pulse peaks. It is 
available only in the PW50 snapshot display.  

The application calculates this measurement using the following equation: 

 
Where:  i indexes negative pulses 

 N is the number of measured time intervals 

  is the time from the prior positive pulse to the current pulse 

  is the time from the current pulse to the next positive pulse 

These measurements operate as other measurements in the sense that a range of 
sectors is defined, and the measurement average and standard deviation 
calculated. The range of the measurement within each sector is determined by the 
cursors.  

Time Peak-to-Trough and Time Trough-to-Peak 

The time peak-to-trough (Time PT) is the time from a positive peak to the next 
negative peak (trough). The time trough-to-peak (Time TP) is the time from a 
trough to the next positive peak. 
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The following figure shows the part of the waveform that the application uses to 
take the measurement: 

 

Figure 49: Time PT and Time TP measurements 

 



 
 
Appendix A: Measurement Algorithms 
 

108 TDSDDM2 Disk Drive Measurements Application
 



 
 

 

                                                                 TDSDDM2 Disk Drive Measurements Application 
 
 

109

 

Appendix B: Track Profile Plots 

Track Profile plots are reference memory waveforms that contain measurement 
results from each track sector. The results are distributed over a 500 point record. 
You can use track profiles to help analyze a measurement in the following ways: 

 Observe sector-to-sector variations in measurements 

 Identify the location of flaws within a track 

 Observe characteristics of measurement variations around a track which 
may be due to causes such as head height variations or surface media defects 

The resulting Track Profile plot represents the value of the measurement as a 
function of sector number over a range of sectors, which can be specified in the 
Inputs/Trigger menu. The Trigger Mode must be set to Sector and you have to 
use the vertical cursors on the oscilloscope for the application to display the 
Sector at Cursor readout. 

Using Track Profiles 

To create a Track Profile plot, refer to Creating and Viewing Track Profile Plots.  

To view ongoing track profile results, set the Sequence Mode to Free Run. When 
the Track Profile plot reaches its 500-point capacity, the application continues to 
acquire data and the plot scrolls across the screen as new points are added and 
old points are deleted.  

About the Track Profile Reference Memory 

At the beginning of the measurement, the reference memory is filled with null 
values. At the end of each sector measurement, the value for that measurement is 
stored in the reference memory and a display cycle is activated. This causes the 
reference memory waveform to sweep across the screen as the measurement 
progresses around the track. You then have a clear indication of the progress of 
the entire measurement over the specified range of sectors. 

Values are stored in the reference memory as one point per measurement result, 
up to a maximum of 500 points. If more than 500 points/measurements are taken, 
the oldest results are discarded. Any unused points at the end of the reference 
memory record are set to null values. 
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Appendix C: GPIB Command Syntax 

This appendix describes the GPIB command syntax that you can use in your 
GPIB program to do the following tasks: 

 Start the TDSDDM2 application 

 Recognize an active application with GPIB protocol 

 Program and read application setup parameters 

 Sequence measurements 

 Read measurement results 

To use GPIB commands with your oscilloscope, you can use the following 
reference materials: 

 The tdsddm2ctrl.c file on the oscilloscope hard drive (located in the 
C:\Program Files\TekApplications\tdsddm2 directory) and on the optional 
applications compact disc contains an example of a GPIB program that can 
execute the application 

 The GPIB Program Example section for guidelines to use while designing a 
GPIB program 

 The Parameters Reference section for incremental units and default values 
of TDSDDM2 parameters 

 The programmer information in the online help of your oscilloscope 

You should be familiar with the following terms when using GPIB command 
syntax: 

Description: Gives the function of the command, conditions of its use, and its 
interactions with other commands.  

Syntax: Gives the valid select and query command forms. The required 
arguments are listed in their proper order.  
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For example, in the syntax definition:  

PATH= <Ad><Ars>  

the arguments <Ad> and <Ars> are required in the order indicated 

Arguments: The arguments to a command are defined along with their range of 
values.  

Returns: Defines the data returned in response to a command query.  

Starting the Application 

To start the TDSDDM2 application, you must send the oscilloscope the 
following GPIB command: 

application:activate "Disk Drive Measurements 2" 

VARIABLE: VALUE TDS COMMAND 

Description: 

VARIABLE:VALUE TDS COMMAND accepts string arguments for a control 
or data variable and a value to which to set the argument.  

Syntax: 

VARIABLE:VALUE “<variable name>”,“<variable value>” 

The arguments <variable name> and <variable value> are required in the order 
indicated. 

VARIABLE:VALUE? “<variable name>” for query 
 
 
 
The following table lists the arguments, their function, and the query returns. 

 
CAUTION. Commands are case and space sensitive. Your program will not 
operate correctly if you do not follow the capitalization and spacing 
precisely.  
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Variable name Variable value Function Query form
application exit Terminates the active

application
Returns the name of the
active application

measurement {TAA, TAA+, TAA-,
Snapshot TAA, PW50,
PW50+, PW50-, Snapshot
PW50, NLTS Initial, NLTS
1st Adjacent, NLTS 2nd
Adjacent, Snapshot NLTS,
SNR, Overwrite,
Resolution, Asperity,
Baseline Shift}

Sets the type of
measurement to take

Returns the
measurement currently
selected

NLTS/Other Parameters
patternDuration String corresponds to a

double positive
For NLTS measuements,
sets the initial length of
time for the pattern
duration value
For SNR measurements,
sets the number of bits
per pattern period for
general patterned data

Returns the pattern
duration

durationTolerance String corresponds to a
positive integer

Sets the tolerance
(accuracy) of the pattern
duration

Returns the tolerance

polynominalIndex String corresponds to a
positive integer

Sets the selected
pseudo–random binary
sequence polynomial
value

Returns the polynominal
index

bitsPerPattern String corresponds to a
positive integer

For SNR measurements,
sets the type of periodic
signal

Returns the Read Signal

threshold String corresponds to a
double positive

For Asperity, defines
threshold--peaks above
this value are an
Asperity.

Return value set for
threshold.

Input Channels
readSignal {Ch1, Ch2, Ch3, Ch4, Ref1,

Ref2, Ref3, Ref4, Math1,
Math2, Math3, Math4}

Sets the Read Signal
input

Returns the Read Signal
selection

readGate {Ch1, Ch2, Ch3, Ch4} Sets the Read Gate input Returns the Read Gate
selection

indexPulse {Ch1, Ch2, Ch3, Ch4} Sets the Index Pulse
input

Returns the Index Pulse
selection

sectorPulse {Ch1, Ch2, Ch3, Ch4} Returns the Sector Pulse
input

Returns the Sector Pulse
selection

Trigger
preambleDuration String corresponds to a

positive double*
Sets the time required to
inialize a disk drive
before the signals
become stable

Returns the time
required to inialize a disk
drive before the signals
become stable

startSector String corresponds to a
positive integer

Sets the sector on which
the measurement starts

Returns the sector on
which the measurement
starts

stopSector String corresponds to a
positive integer

Sets the sector on which
the measurement stops

Returns the sector on
which the measurement
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limitTestState {On, Off} Sets the state of the limit
test

Returns the state of the
limit test

limitTestUpper String corresponds to a
positive double*

Sets the upper limit value Returns the upper limit
value

limitTestLower String corresponds to a
positive double*

Sets the lower limit value Returns the lower limit
value

Filters
filter1CutoffFreq or
filter2CutoffFreq

String corresponds to a
positive double*

Sets the cutoff frequency Returns the cutoff
frequency

filter1DestinationName or
filter2DestinationName

{Ref1, Ref2, Ref3,
Ref4,None}

Sets Filter Destination to
a Ref or None

Returns Filter
Destination Selection

filter1Slope or
filter2Slope

{12 dB/oct, 24 dB/oct, 36
dB/oct, 48 dB/oct, 60
dB/oct, 72 dB/oct, 84
dB/oct}

Sets the slope of the filter
in dB units

Returns the slope of the
filter in dB units

filter1State or
filter2State

{On, Off} Sets the state of the filter Returns the state of the
filter

filter1Type or
filter2Type

{Lowpass, Highpass} Sets the type of filter Returns the type of filter

General
gating {On, Off} Sets the state of gating Returns the state of

gating
hysteresis String corresponds to a

double positive
Sets the hysteresis value Returns the hysteresis

value
Sequencer
sequencerMode {Free Run, Single} Sets the Sequencer

Mode
Returns the Sequencer
Mode

sequencerState {Ready, Paused,
Sequencing}

Sets the state of the
sequencer

Returns the state of the
sequencer

Result Variables
resultFor {TAA, TAA+, TAA-,

Snapshot TAA, PW50,
PW50+, PW50-, Snapshot
PW50, NLTS Initial, NLTS
1st Adjacent, NLTS 2nd
Adjacent, Snapshot NLTS,
SNR, Overwrite,
Resolution, Asperity,
Baseline Shift}

Sets the measurement
for which results are
requested

Returns the selected
measurment

Profiler
profilerState {On, Off} Sets the state of the

Profiler plot
Returns the state of the
Profiler plot

profilerDestination {Ref1, Ref2, Ref3, Ref4} Sets the destination
reference memory of the
Profiler plot

Returns the destination
reference memory of the
Profiler plot
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limitTestState {On, Off} Sets the state of the limit
test

Returns the state of the
limit test

limitTestUpper String corresponds to a
positive double*

Sets the upper limit value Returns the upper limit
value

limitTestLower String corresponds to a
positive double*

Sets the lower limit value Returns the lower limit
value

Filters
filter1CutoffFreq or
filter2CutoffFreq

String corresponds to a
positive double*

Sets the cutoff frequency Returns the cutoff
frequency

filter1DestinationName or
filter2DestinationName

{Ref1, Ref2, Ref3,
Ref4,None}

Sets Filter Destination to
a Ref or None

Returns Filter
Destination Selection

filter1Slope or
filter2Slope

{12 dB/oct, 24 dB/oct, 36
dB/oct, 48 dB/oct, 60
dB/oct, 72 dB/oct, 84
dB/oct}

Sets the slope of the filter
in dB units

Returns the slope of the
filter in dB units

filter1State or
filter2State

{On, Off} Sets the state of the filter Returns the state of the
filter

filter1Type or
filter2Type

{Lowpass, Highpass} Sets the type of filter Returns the type of filter

General
gating {On, Off} Sets the state of gating Returns the state of

gating
hysteresis String corresponds to a

double positive
Sets the hysteresis value Returns the hysteresis

value
Sequencer
sequencerMode {Free Run, Single} Sets the Sequencer

Mode
Returns the Sequencer
Mode

sequencerState {Ready, Paused,
Sequencing}

Sets the state of the
sequencer

Returns the state of the
sequencer

Result Variables
resultFor {TAA, TAA+, TAA-,

Snapshot TAA, PW50,
PW50+, PW50-, Snapshot
PW50, NLTS Initial, NLTS
1st Adjacent, NLTS 2nd
Adjacent, Snapshot NLTS,
SNR, Overwrite,
Resolution, Asperity,
Baseline Shift}

Sets the measurement
for which results are
requested

Returns the selected
measurment

Profiler
profilerState {On, Off} Sets the state of the

Profiler plot
Returns the state of the
Profiler plot

profilerDestination {Ref1, Ref2, Ref3, Ref4} Sets the destination
reference memory of the
Profiler plot

Returns the destination
reference memory of the
Profiler plot
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Logging Results
<meas>logAnnotate* Any string from 1 to 20

characters from A to Z
and/or zero to nine

Provides custom
annotation to the
statistics log file; see
measurement in this
table for <meas> choices

Returns annotation value
if set

<meas>loggerDestination Any string from 1 to 8
characters from A to Z
and/or zero to nine

Sets the statistics log file
name; see measurement
in this table for <meas>
choices

Returns  the statisics log
file name

<meas>logger {Reset} Clears the current
statistics log file; see
measurement in this
table for <meas> choices

No query form

<meas>loggerState {On, Off} Sets the state of the
statistics log; when on,
the statistics from the
current acquisition are
logged; see
measurement in this
table for <meas> choices

Returns the state of the
data log

Save/Recall
setup {Default, Recall, Save} Causes a Save or a

Recall to occur
No query form

recallName Any string from 1 to 8
characters from A to Z
and/or zero to nine

Sets the recalled setup
file name

Returns the recalled
setup file name

saveName Any string from 1 to 8
characters from A to Z
and/or zero to nine

Sets saved setup file
name

Returns the saved setup
file name

*  You can enter positive double values two ways; for example, 0.000256 or 2.56E–4 (IEEE format).
** Custom annotation in the data log file is only available through GPIB execution of the application.

 
Before you can request result queries, be sure that your program contains the 
following sequence of commands:  

measurement 

sequenceMode 

sequenceState 

resultFor 

After this sequence, you can query the results. If you have a subsequent 
sequencing for the same measurement, you must issue another resultFor. 
You need to use the VARIABLE:VALUE? form to enter measurement results 
queries in your GPIB program. The following table lists the measurement results 
queries for the measurement selected in the resultFor variable. 
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Variable name Function
1st adj trans Returns the NLTS value caused by a transition in

the previous bit cell, which opposes the transition
in the current bit cell

2nd adj trans Returns the NLTS value caused by a transition,
which is two bit cells before the current bit cell

Amplitude asymmetry Only for TAA Snapshot, returns the percent of
amplitude asymmetry with zero indicating total
symmetry.

asperity {0 to 9} Returns the sector number and time in which the
asperity occurred for no more than the last 10
asperities

Estm Pattern Duration Returns the estimated duration of the pattern
frequency Returns the frequency value
init mag Returns the initial magnetization value for NLTS

only
m1 Returns the magnitude value for the low

frequency signal
m2 Returns the magnitude value for the high

frequency signal
max Returns the maximum value
mean Returns the mean value
meanPercent Returns the mean value as a percentage for

Baseline Shift measurement
min Returns the minimum value
num avg Returns the number of peaks, troughs or

peak/trough pairs used for the average values
numAvgAtF1 Returns the number of peak and trough pairs of

the high frequency pattern
numAvgAtF2 Returns the number of peak and trough pairs of

the low frequency pattern
overwrite Returns the amount of residual signal remaining

from a previous write when new data is written to
the same location

pass Returns Pass 1 or Pass 2 for the Resolution and
Overwrite measurements

PW50 Returns the average pulse width at 50% of the
peak value measured around a complete track

PW50+ Returns the average pulse width at 50% of the
positive peaks value

PW50- Returns the average pulse width at 50% of the
negative peaks value

PW50 res Returns the number of samples for Pulse Width
50%

resolution Returns the total number of samples
sector number Returns the number of sectors included in the

measurement
statSNR Returns the statistics for the SNR measurement
stdDev Returns the standard deviation value
TAA Returns the average peak–to–peak value of data

from the Read waveform
TAA+ Returns the average positive peak value
TAA- Returns the average negative peak value
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taaAtF1 Returns the TAA value of the high frequency
pattern

taaAtF2 Returns the TAA value of the low frequency
pattern

Time asymmetry Returns the ability of the head and the media to
process positive and negative transitions
identically; only for TAA  and PW50 snapshots

Time PT Returns the value of the elapsed time from a
positive peak to the next negative peak (trough)

Time TP Returns the value of the elapsed time from a
negative peak (trough) to the next positive peak

total asperities Returns the total number of asperities
User Pattern Duration Returns the actual duration of the pattern

 
The following table lists the results returned for various measurements: 

Measurement Results returned
TAA, TAA+, TAA-,
PW50, PW50+,
PW50-

mean, max, min, stdDev, statSNR, num avg, sector
number

Snapshot TAA TAA, TAA+, TAA-, Amplitude asymmetry, num avg, Time
PT, Time TP, Time Asymmetry,  resolution, frequency,
hysteresis, sector number

Snapshot PW50 PW50, PW50+, PW50-, PW50 res, num avg, Time PT,
Time TP, Time asymmetry, resolution, frequency,
hysteresis, sector number

NLTS Initial, NLTS
1st Adjacent, NLTS
2nd Adjacent

mean, min, max, stdDev, num avg, sector number, User
Pattern Duration, Estm Pattern Duration

Snapshot NLTS init mag, 1st adj trans, 2nd adj trans, num avg, sector
number, User Pattern Duration, Estm Pattern Duration

SNR mean, min, max, stdDev, num avg, sector number, User
Pattern Duration, Estm Pattern Duration

Asperity total asperities, sector number, asperity{0–9}
Overwrite pass, overwrite, m1, m2, frequency, sector number
Resolution pass, resolution, taaAtF1, numAvgAtF1, taaAtF2,

numAvgAtF2, sector number
Baseline Shift meanPercent, mean, max, min, stdDev, statSNR, num

avg, sector number
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